WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] disable background scrolling (5 posts)

  1. polyfade
    Member
    Posted 7 months ago #

    I realize this plugin does not use fancybox v2 where disabling the background from scrolling is the default.

    But, is there any way with this plugin to disable the background from scrolling when fancybox is active? Otherwise, it doesn't make sense why you'd want this to occur and make the viewer lose his/her spot on the page.

    http://wordpress.org/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 7 months ago #

    It makes sense to disable scrolling for the background... But it will take a mod to the script. Going on the "to figure out" list, unless you can provide a quick code patch ;)

  3. RavanH
    Member
    Plugin Author

    Posted 7 months ago #

    In fact, I think it's done: Could you uninstall the current version and install fresh from the WordPress installer? It should now capture all scrolling as long as the jQuery mousewheel script is included...

  4. polyfade
    Member
    Posted 7 months ago #

    RavanH,

    Thanks for the quick response. Yes, activating that option, "Include the Mousewheel jQuery extension script to allow gallery browsing by mousewheel action" did the trick.

    I guess this inadvertently solves the problem since the mousewheel's purpose would be set to scroll though the gallery instead of using the scroll action for any other purpose.

    Cheers!

  5. RavanH
    Member
    Plugin Author

    Posted 7 months ago #

    I guess this inadvertently solves the problem since the mousewheel's purpose would be set to scroll though the gallery instead of using the scroll action for any other purpose.

    In the old version, that option did only capture scrolling when the mouse pointer was over the image. Now, scrolling is always captured as long as the lightbox is open...

Reply

You must log in to post.

About this Plugin

About this Topic