WordPress.org

Ready to get started?Download WordPress

Forums

Disable autosave? (7 posts)

  1. DanielWestman
    Member
    Posted 5 years ago #

    Since I upgraded to 2.5.1 my autosave has been screwed up.
    It autosaves each and every second and slows down the internet like hell.

    How do I disable the autosave function when writing new posts?

  2. ImJustCreative
    Member
    Posted 5 years ago #

    This is a common problem that is still causing me huge problems, there is a thread here that you might want to add this post to rather than create more and more posts on the same subject.

    http://wordpress.org/support/topic/172302/page/2?replies=31#post-746691

    But I have exactly the same problem, I have posted my findings on the post below just this morning.

  3. ImJustCreative
    Member
    Posted 5 years ago #

    Not being a coder, I decided to take a crack myself. I think I have found a make do hack, until it can be solved properly.

    Edit your 'autosave.js' file which can be found in 'WP-includes'>'JS'>'autosave.js'

    There are some values on line 5-7:

    jQuery(function($) {
    	autosaveLast = $('#post #title').val()+$('#post #content').val();
    	autosavePeriodical = $.schedule({time: autosaveL10n.autosaveInterval * 1000, func: function() { autosave(); }, repeat: true, protect: true});

    All i did was take a guess and increase these values to some silly high number.

    So far, after creating a post and manually saving it, the autosave has not kicked in. This giving me time to actually write a post etc.

    Im not too sure what these values equate to in time wise, milliseconds etc, but it appears to work.

    You could try removing the complete 'autosave.js' file and see what happens, I may try that later. Just back it up.

    Hope that helps for the time being.

    [sig moderated]

  4. lateefx
    Member
    Posted 5 years ago #

    Guys...just save yourselves A LOT of time and Install this plugin...this is absolutely brilliant and will END this ANNOYING AUTOSAVE FEATURE.

    http://www.untwistedvortex.com/2008/06/27/adjust-wordpress-autosave-or-disable-it-completely

  5. Exper
    Member
    Posted 5 years ago #

    That's good and helped me to resolve the Revisions problem too.

    I've prepared a plugin version out of it:
    http://exper.3drecursions.com/2008/07/24/wordpress-revisions-and-autosave-problem/
    download it at the end of the post.

  6. Exper
    Member
    Posted 5 years ago #

    I've created three plugins using the solutions I previously reported:
    Disable Revisions and Autosave plugins

  7. hakan___
    Member
    Posted 5 years ago #

    remove the wp_enqueue_script('autosave'); line on your post-new.php (which is located in wp-admin folder) and your posts will not be autosaved anymore.

Topic Closed

This topic has been closed to new replies.

About this Topic