WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Disable auto-tweet/Facebook (9 posts)

  1. toby1kenobi
    Member
    Posted 1 year ago #

    Hi there,

    We're using Jetpack on a site we currently have in development, and it's hooked up to a Facebook page and Twitter account. New post creation results in an automatic tweet and a Facebook update - we need to disable this in dev, ideally we'd like to retain the associations however (for testing share buttons mainly).

    Is this possible, I can't find it in the config or documentation?

    Thanks,

    Toby

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    You can disable Publicize by going to Settings > Sharing in your dashboard, and clicking on the 'X' symbol next to the Connection you want to disable.

    The sharing buttons won't be affected by the change, since they are not linked to the Publicize feature.

    You can read more about the Publicize feature here:
    http://jetpack.me/support/publicize

  3. toby1kenobi
    Member
    Posted 1 year ago #

    Ah, I did not realise that, thanks for the explanation, much appreciated.

    Toby

  4. ClevelandWebDeveloper
    Member
    Posted 1 year ago #

    Hi Jeremy, Thanks for the work you have done on the Jetpack plugin it's great.

    One suggestion I would make is that it would be nice to maintain the connections but have the option for default posts not to be shared.

    For example when I go to publish my post and it shows my Twitter, LinkedIn, etc...I do like the fact that I am able to share with my social networks right there from within the WordPress admin, but I would prefer the default to be unchecked (meaning don't share). The reason being that the majority of my posts I don't want to broadcast because I think that is overkill and will get annoying for my friends if I'm always just posting about my own stuff.

    Anyways I do appreciate the plugin it's really well done just wanted to share my thoughts.

    Thanks,
    Justin

  5. wkoffel
    Member
    Posted 7 months ago #

    I'll second this request. I'm surprised there's no way to disable the publicize features in development without also breaking all the oauth on a live copy of the site.

    More than once I've been developing on a copy of my site and posted a localhost URL by accident to Twitter, Facebook, LinkedIn. It creates an embarrassing mess. Any thoughts on a way to make that cleaner?

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    I would prefer the default to be unchecked (meaning don't share).

    You can do so by following the instructions here:
    http://jetpack.me/2013/10/15/ever-accidentally-publicize-a-post-that-you-didnt/

    I'm surprised there's no way to disable the publicize features in development without also breaking all the oauth on a live copy of the site.

    Your development site and your production site should not share the same Jetpack connection. If they do, I would suggest that you enable Jetpack's Development mode as explained here:
    http://jetpack.me/support/development-mode/

    If you share your Jetpack connection between 2 sites, you may end up creating several conflicts by using 2 different URLs for a single connection.

  7. wkoffel
    Member
    Posted 7 months ago #

    Thanks Jeremy. I tried that filter for 'publicize_checkbox_default' and it doesn't seem to have any effect for me. I still see in the New Post admin interface that it's going to be publicized the all my connections. WP 3.7.1, latest Jetpack.

    Any thoughts?

    Jetpack automatically turns on development mode when you have a domain of 'localhost', which I happen to when developing, so that's working fine. But the issue for me is that Publicize is using the same oauth to social media sites in both environments. If I disconnect them all in development, then they are also disconnected in production. Are those going through my WP connection in some way I don't understand?

    I'd just like to be able to disconnect them all in dev, while leaving them in production. Or even better, have a way to globally disable publicize in my dev environment. If I could get the 'publicize_checkbox_default' working, I suppose I could just add an environment check into that filter, that'd probably do the trick.

  8. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    I tried that filter for 'publicize_checkbox_default' and it doesn't seem to have any effect for me.

    Once you add the filter, the Publicize options are still there but they're unchecked by default, like so:
    http://i.wpne.ws/Swja

    But the issue for me is that Publicize is using the same oauth to social media sites in both environments. If I disconnect them all in development, then they are also disconnected in production.

    I'm not sure how you managed to do that: 2 different sites should not be able to share the same Jetpack connection, let alone the same Publicize connections.
    I guess I don't really understand how your development site is set, and how you deploy from the dev site to production.

    Do you use the same site URL on both sites, and switch from one to the other by editing your hosts' file?
    If you use a different URL on your staging site, you can separate the 2 Jetpack installations by going to the Jetpack menu in your dashboard, and disconnecting then reconnecting to WordPress.com. It will create a new connection for your dev site, and you will then be able to make changes on your dev site (like deactivating the Publicize module) without affecting the production site.
    You will then need to make sure you don't copy the jetpack_options row (in wp_options) when copying the database from dev to prod.

    I hope this helps.

  9. wkoffel
    Member
    Posted 7 months ago #

    Thanks, definitely helps. So first off, that checkbox default works fine, the confusion on that was my fault.

    Regarding the Jetpack connection, I use Duplicator (http://wordpress.org/plugins/duplicator/) to pull down the production site periodically so I have the latest content to develop against locally. What must be happening is that the database settings and connection tokens to Jetpack are being duplicated a bit too well. :-)

    So problem solved, I have two options. Change the checkbox default in development, or even easier, just disconnect jetpack whenever I'm in development mode and reconnect only to test specific jetpack features.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.