WordPress.org

Ready to get started?Download WordPress

Forums

disable author bio on posts (6 posts)

  1. Verius88
    Member
    Posted 3 years ago #

    How can I stop the author bio from being displayed on posts. Currently using Twenty Ten theme with WordPress 3.0.4

  2. alchymyth
    Forum Moderator
    Posted 3 years ago #

    edit single.php and remove the corresponding code:
    http://wordpress.pastebin.com/T0TkYtfe

    btw:
    consider creating a child theme (http://codex.wordpress.org/Child_Themes) because twenty ten as the default theme of wp3 will be overwritten with your next upgrade of the wordpress version.

  3. Verius88
    Member
    Posted 3 years ago #

    thanks! it worked like a charm! :)

  4. laptophobo
    Member
    Posted 2 years ago #

    How about if I wanted to disable the author only on some posts? For example, posts that end up on static (about us) pages should have no author. But posts that go to the Articles section should have author.
    Help!
    Thanks!

  5. alchymyth
    Forum Moderator
    Posted 2 years ago #

    @laptophobo

    For example, posts that end up on static (about us) pages should have no author.

    wouldn't that be a page anyway?

    if you are working with twenty ten, then this would be in loop-page.php, and afaik, there is no author infor on (static) pages.

    can you be more specific and post a link to your site, to illustrate the issue?

  6. laptophobo
    Member
    Posted 2 years ago #

    The parent theme I'm using is notes-blog. But, what I ended up doing was modifying the CSS -- targeting a specific part of the site, as so:

    body.single .entry-meta
    	display: none;
    }

    It would be nice if there were a plug-in that managed authors bios.

Topic Closed

This topic has been closed to new replies.

About this Topic