WordPress.org

Ready to get started?Download WordPress

Forums

Simple Ajax Chat
[resolved] Directory setup (8 posts)

  1. evertsaar
    Member
    Posted 4 months ago #

    Hi Jeff!

    I've got an issue where my wp-content folder bears another name. My configuration file should be set up properly, but it just seems wp-content is hard-coded into the plugin.

    Is there an easy fix or am maybe I'm missing out on something?

    Thanks!

    Evert

    https://wordpress.org/plugins/simple-ajax-chat/

  2. Jeff Starr
    Member
    Plugin Author

    Posted 4 months ago #

    I'm not sure without looking into it, which I now have on the list for the next update.

    Thank you for the feedback!

  3. evertsaar
    Member
    Posted 4 months ago #

    Hey thanks!

    I probably got into the habit of renaming the folder after reading something that you wrote! :)

    Loving the 'simplicity' of the plugin. Will update the links just now and use that till next update. Thanks for making it free. Good Karma your way!

    Evert

  4. Jeff Starr
    Member
    Plugin Author

    Posted 4 months ago #

    Lol, I've never recommended renaming the /wp-content/ folder, but understand that there are reasons for doing so. Thanks for the good karma, I can always use it :)

  5. evertsaar
    Member
    Posted 4 months ago #

    Hi again!
    I'm trying to use this plugin on another page and I've run into problems. It runs fine on fresh installs of WordPress (also with wp-content changed), but with an installation copied from a production site it generates the following notice after activation:
    The plugin generated 203 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    Using the 'sac' shortcode it displays the form alright, but inside are some more errors:

    WordPress database error: [Table 'wordpress.wp_ajax_chat' doesn't exist]
    SELECT * FROM wp_ajax_chat ORDER BY id DESC LIMIT 999

    You need at least one entry in the chat forum!
    Also the submit button redirects to a blank: http://127.0.0.1/wordpress/wp-content/plugins/simple-ajax-chat/simple-ajax-chat-admin.php

    So it seems the plugin failed to create its table. Do you think this is due to weird folder permissions I have or something else? As far as I could see the permission are the same on the site the plugin runs fine and the one it doesn't. Maybe you can spot something. I can't seem to figure it out.

    Thanks and sorry for buggin'!

  6. Jeff Starr
    Member
    Plugin Author

    Posted 4 months ago #

    It sounds like something is interfering.. basically the plugin works best for typical WP setups. The further things are changed from there, the more likely there are to be issues, simply because they aren't accounted for in the script.

  7. evertsaar
    Member
    Posted 4 months ago #

    After a long afternoon of creating countless local WP installs and deactivating plugins in various successions it was a small glitch in wp-config that was messing stuff up. Gotta love this work!

    Anyway, it works brilliantly now! Can't wait to start customising it! Thanks again!

  8. Jeff Starr
    Member
    Plugin Author

    Posted 4 months ago #

    Glad to hear you got it working! Thanks for the follow-up post :)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.