WordPress.org

Ready to get started?Download WordPress

Forums

Shareaholic | share buttons & related posts
[resolved] Directory permissions error (8 posts)

  1. Tate-Ramingham
    Member
    Posted 1 year ago #

    Getting the following error after updating the plugin and re-saving the settings:

    WARNING: Your spritegen folder is not writeable by the server! Need Help?

    Here are the specific error strings:
    Warning: fopen(/home/0/2/0/1559/1559/public_html/wp-content/uploads/shareaholic/spritegen/jquery.shareaholic-publishers-sb.min.js) [function.fopen]: failed to open stream: No such file or directory in /home/USERNAME/public_html/wp-content/plugins/shareaholic/includes/shrsb_settings_page.php on line 392

    Warning: fopen(/home/0/2/0/1559/1559/public_html/wp-content/uploads/shareaholic/spritegen/jquery.shareaholic-share-buttons.min.js) [function.fopen]: failed to open stream: No such file or directory in /home/USERNAME/public_html/wp-content/plugins/shareaholic/includes/shrsb_settings_page.php on line 392

    Warning: fopen(/home/0/2/0/1559/1559/public_html/wp-content/uploads/shareaholic/spritegen/sprite.css) [function.fopen]: failed to open stream: No such file or directory in /home/USERNAME/public_html/wp-content/plugins/shareaholic/includes/shrsb_settings_page.php on line 392

    Warning: fopen(/home/0/2/0/1559/1559/public_html/wp-content/uploads/shareaholic/spritegen/shareaholic-share-button.css) [function.fopen]: failed to open stream: No such file or directory in /home/USERNAME/public_html/wp-content/plugins/shareaholic/includes/shrsb_settings_page.php on line 392

    Warning: fopen(/home/0/2/0/1559/1559/public_html/wp-content/uploads/shareaholic/spritegen/sprite.png) [function.fopen]: failed to open stream: No such file or directory in /home/USERNAME/public_html/wp-content/plugins/shareaholic/includes/shrsb_settings_page.php on line 392

    Warning: fopen(/home/0/2/0/1559/1559/public_html/wp-content/uploads/shareaholic/spritegen/shareaholic-publishers-mini.png) [function.fopen]: failed to open stream: No such file or directory in /home/USERNAME/public_html/wp-content/plugins/shareaholic/includes/shrsb_settings_page.php on line 392

    Warning: fopen(/home/0/2/0/1559/1559/public_html/wp-content/uploads/shareaholic/spritegen/arrow_up.png) [function.fopen]: failed to open stream: No such file or directory in /home/USERNAME/public_html/wp-content/plugins/shareaholic/includes/shrsb_settings_page.php on line 392

    Warning: fopen(/home/0/2/0/1559/1559/public_html/wp-content/uploads/shareaholic/spritegen/arrow_down.png) [function.fopen]: failed to open stream: No such file or directory in /home/USERNAME/public_html/wp-content/plugins/shareaholic/includes/shrsb_settings_page.php on line 392

    Warning: fopen(/home/0/2/0/1559/1559/public_html/wp-content/uploads/shareaholic/index.html) [function.fopen]: failed to open stream: No such file or directory in /home/USERNAME/public_html/wp-content/plugins/shareaholic/includes/shrsb_settings_page.php on line 392

    Warning: fopen(/home/0/2/0/1559/1559/public_html/wp-content/uploads/shareaholic/spritegen/index.html) [function.fopen]: failed to open stream: No such file or directory in /home/USERNAME/public_html/wp-content/plugins/shareaholic/includes/shrsb_settings_page.php on line 392

    So I followed the instructions and the spritegen directory permissions were changed to 775. This didn't fix the issue.

    Also the spritegen directory wasn't named spritegen. It was named spritegen_default. So I tried changing that to just spritegen and that too didnt' work.

    I've tried removing the plugin and reinstalling it. Nothing works.

    I'm out of ideas and have no clue why it is not working

    http://wordpress.org/extend/plugins/shareaholic/

  2. lmae222
    Member
    Posted 1 year ago #

    I am having the same problem. I tried the 775 and the 777 deal and also tried changing all image folders under the uploads file to 777 as well... nothing seems to be working.

    I've been looking for an answer all morning... this link takes you to a site that talks about a backup folder, which I cannot find in either FileZila or WordPress... http://silkenhut.com/warning-your-backup-directory-is-not-writable-wordpress-error/

    And heres a link that says theres nothing you can do about it... http://wordpress.org/support/topic/upgrading-failes-no-chmod-777-does-not-work

    I hope I figure this out today!

  3. lmae222
    Member
    Posted 1 year ago #

    there is also talk that moving the .htaccess file from a sub folder to the root folder is the key...

  4. lmae222
    Member
    Posted 1 year ago #

    I just found something that FINALLY worked for me... at least for now...

    In WordPress, go to the SexyBookmarks page and scroll down to compatibility settings.

    Under Custom Path to Shareaholic File Resources there was something written there that was different then the default. I copied the default path and my changes were finally saved.

  5. Celeste - Shareaholic
    Member
    Posted 1 year ago #

    Hi everyone! Here's a more current support doc that addresses the spritegen errors: http://support.shareaholic.com/customer/portal/articles/386748-how-do-i-fix-the-spritegen-directory-write-errors-

    Additional Notes:
    Usually, the Default Path and Custom Path should match; so, if you find that for some reason they do not and all else fails, copy the Default Path into the Custom Path input box, and that should do the trick. :)

  6. security_man
    Member
    Posted 1 year ago #

    c reign... did all of that, still no love.

    Maybe this will be a clue: The link to the spritegen folder is not correct in the error message. Where it says "WARNING: Your spritegen folder is not writeable by the server! Need Help?"

    the word spritegen links to to domain.com/spritegen not domain.com/wp-admin/uploads/shareaholic/spritegen

    i have the custom path set correctly and the chmod on it to 777 as well, just to make sure. any ideas?

  7. Celeste - Shareaholic
    Member
    Posted 1 year ago #

    Hey security_man, the custom path shouldn't link directly with the spritegen folder. It should link to the shareaholic directory under uploads. Make sure that your custom path is identical to the default path.

    If you find that there is still an error, try performing a clean install as described in this article, because something may have gone wrong in the initial install.

    After saving your SexyBookmarks settings, verify the folder location in your uploads directory and permissions. If the Custom Path is auto-filled with something other than what you see the in the Default Path, please copy that path to me in your response.

  8. danielleom
    Member
    Posted 1 year ago #

    Hey Imae 222. I created an user (for some reason I didnt have one) just to thank you. Great that you shared. Just worked for me as well. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic