WordPress.org

Ready to get started?Download WordPress

Forums

Directory Listing Denied Error (5 posts)

  1. sbishop33
    Member
    Posted 9 years ago #

    Installed WordPress in c:\inetpub\wwwroot\dsbwebsite\wordpress. When trying to login as admin I receive the following error message:
    "Directory Listing Denied
    The Virtual Directory does not allow contents to be listed."
    After looking at the posts on this issue I cannot solve the problem. Index.php is in the /WordPress folder as it should be. If I browse to the Index.php file the blog screen opens and I have access to all of the functions of the blog...except I cannot login.
    Is this an IIS issue? Any other thoughts?
    Thanks, everyone.
    sb

  2. refly
    Member
    Posted 9 years ago #

    It seems like you didn't set the default index in IIS.
    Try to set default index file to default.htm, default.asp, index.php

  3. sbishop33
    Member
    Posted 9 years ago #

    Thanks for the posts. I reached the same solution after searching the MS site for "Directory Listing Denied". Index.php was not one of the choices for default documents for my website. 'Default.htm', 'Default.asp', 'Index.htm', and 'iisstart.htm' were listed, but no 'Index.php'. Once that was added to the list, everything works as it should.
    This is corrected by starting the IIS Console, selecting the website on the treeview on the left, right-clicking the website and selecting properties, then clicking on the "Documents" tab in the Properties dialog box. Click the "Add" button to add 'Index.php' as a default document to the list, and make sure that the "Enable Default Document" box is checked. Click "OK" or "Apply" and everything is good to go.

  4. Vidar
    Member
    Posted 9 years ago #

    give him a break guys, he's an mscp.

    P.S: my nipples look like milkduds

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.