WordPress.org

Ready to get started?Download WordPress

Forums

Directory exposed :((((( (7 posts)

  1. finallyanime
    Member
    Posted 4 years ago #

    Hello, through a bunch of moves and whatnot, I've moved from finallyanime.com/blog TO finallyanime.com & I'm almost done. I just have a couple more problems, and one of those problems is an exposed directory of the old site, which doesn't exist.

    In fact, I keep deleting the folder from my directory, but it KEEPS COMING BACK!!! can someone either help me get rid of this folder forever or tell me how to keep people from browsing it?

    Btw: is there something about a "silence is golden" file that stops that? I don't see how, but when I noticed them, I thought it was a cruel joke, but I'm not quite sure. Can someone help me?

  2. Dagon Design
    Member
    Posted 4 years ago #

    Do you mean that if someone visits the folder like this:

    http://yoursite.com/thefolder/

    They are getting a listing of files?

    If so, there are several ways of fixing that. One method is to put an empty file in that folder called index.php - when they view the folder, it will default to loading index.php, and nothing will be displayed.

    Another (better) option is adjusting the site settings through the .htaccess file to prevent the listing of files in directories:

    Just add this to your .htaccess file:

    Options –Indexes

  3. Joni
    Member
    Posted 4 years ago #

    I also like to drop an index.html file into directories where I don't want folks snooping around ... like this. (Pulp Fiction fans might get a chuckle out of it.)
    http://pixelita.com/temp/

    It's not an actual 403: Forbidden page, just an index.html file that I drop into my directories.

  4. Dagon Design
    Member
    Posted 4 years ago #

    Nice :)

  5. finallyanime
    Member
    Posted 4 years ago #

    Ahh, I see. Thanks :) I'll hafts get on that, but why in the heck is this "silence is golden stuff?"

  6. Joni
    Member
    Posted 4 years ago #

    Your "Silence is Golden" issue might be this:
    http://wordpress.org/support/topic/190290?replies=3

  7. Vladimir Garagulya
    Member
    Posted 4 years ago #

    If you meet with similar problem you can fix directory browsing issue automatically. Check the "Silence is Golden Guard" plugin at
    http://wordpress.org/extend/plugins/silence-is-golden-guard/
    It supports both ways: empty index.php and .htaccess -Indexes option.

Topic Closed

This topic has been closed to new replies.

About this Topic