WordPress.org

Ready to get started?Download WordPress

Forums

Store Locator Plus
[resolved] Directions link returns 404 error (17 posts)

  1. mcmahant
    Member
    Posted 1 year ago #

    Great plugin, I purchased the Pro upgrade to show my support.

    Unfortunately when I click the "directions" link on any result I get a 404 error from Google. I noticed the link produced by the plugin looks something like this:
    maps.googleapis.com/maps?saddr=blahblahblahblah

    if I change it to:
    maps.google.com/maps?saddr=blahblahblahblah
    everything works fine

    http://wordpress.org/extend/plugins/store-locator-le/

  2. mcmahant
    Member
    Posted 1 year ago #

    Here's the site I'm currently working off of
    http://www.graphicdesignhero.com/talonvise/store-locator/

  3. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    Ah... interesting... I was advised to change the maps URL for the USA maps to "maps.googleapis.com" not "maps.google.com". Forgot I did that and it turns out the problem I was trying to solve had NOTHING to do with it. The Google servers went all "wonky" the other night and were throwing up erroneous "violation of terms" messages to random users.

    3.9 will change this back & fix the problem, but that is a few days away.

    In the meantime edit slp-adminui_mapsettings_class.php around line 524 (in get_map_domains()) and change this:
    __('United States' ,'csa-slplus')=>'maps.googleapis.com',
    to this
    __('United States' ,'csa-slplus')=>'maps.google.com',

    For those that are not code hacks, 3.9 will fix it. You can always go back to 3.8.18 with the "Developer" tag on this page. Download the zip, deactivate slp (your settings/data will remain), delete slp, add new plugin & upload the 3.8.18 zip, re-activate.

  4. FahrenheitCG
    Member
    Posted 1 year ago #

    EDIT: Had the same problem and changing the code didn't seem to do the trick, but 1/2 hour later it's working... go figure.

  5. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    The cache needs to clear. Shift + reload from the browser window can help.

  6. JMH Design
    Member
    Posted 1 year ago #

    All together - great plugin! However, I also made your suggested update to the file slp-adminui_mapsettings_class.php to no avail after cleaning my cache and everything. I even tested in a clean browser (no cookies, history, cache, etc). Just curious.. when do you expect version 3.9 to be released? Thanks much!

  7. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    3.9 is in testing... soon... maybe tomorrow if all goes well.

  8. JMH Design
    Member
    Posted 1 year ago #

    Hi there, I upgraded to version 3.9, and am still experiencing the same issue. Was this corrected in version 3.9?

  9. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    Should have been. The directions link should be maps.google.com for US-based maps. Are you seeing something different?

  10. JMH Design
    Member
    Posted 1 year ago #

    Odd - I even completely removed and re-installed the plugin and I'm still getting maps.googleapis.com/... after clearing cache, refreshing, etc. Interestingly, I'm looking in the file slp-adminui_mapsettings_class.php and it seems that you have fixed the URL to point to maps.google.com. Not sure what's happening.

  11. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm... let me look at it closer. It shouldn't be pulling from the geocode API address but maybe I screwed up the URLs somehow.

  12. JMH Design
    Member
    Posted 1 year ago #

    That would be tremendous of you! :)

  13. haysuess
    Member
    Posted 1 year ago #

    The same thing is happening for me. First I manually changed the code like you said, then I updated to 3.9. I cleared caches, used different computers, etc.

    I have no clue where it's pulling maps.googleapis.com from, just like JMH design...is it stored in the database somewhere and pulling from there?

  14. haysuess
    Member
    Posted 1 year ago #

    Yep, that was it. The plugin stored maps.googleapis.com under sl_google_map_domain inside the wp_options table. Hope that helps.

  15. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    @haysuess - Good catch I will go dig that out squash that bug in a SLP 3.9.1 update.

  16. Charleston Software Associates
    Member
    Plugin Author

    Posted 1 year ago #

    The problem is with anyone that updated to the prior version where the direction link was set. The quick fix:

    Go to Map Setting, change the setting under "Map / Country" for "Map Domain" to something different. Save. Change it back to "United States". Save.

    Version 3.9.1 will fix incorrect maps.googleapis.com settings automatically.

  17. JMH Design
    Member
    Posted 1 year ago #

    You rock! I just tried your suggestion and everything is copacetic now. Thanks much.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.