WordPress.org

Ready to get started?Download WordPress

Forums

Slideshow
[resolved] Direct fade + position:absolute + IE8 = bug! (8 posts)

  1. jeffrod
    Member
    Posted 1 year ago #

    I have a slideshow that I am using as a rotating background for my homepage. I use position:absolute to get it to line up as the background. When I use the Direct Fade transition, I get a bug with IE8 after the last slide, when the slideshow is supposed to restart with the first slide. It fades to white (direct fade isnt supposed to fade to white) and stays white for a full slide duration. Then it transitions back to the first slide but now all the transitions are screwed up. Either they transition to nothing, or they transition to the correct slide and then blink to the wrong slide. Its really confusing so I created a video.

    http://www.youtube.com/watch?v=h-j1lDc5cb4

    If I remove position:absolute or use the Fade transition, the jibba-jabba goes away.

    http://wordpress.org/extend/plugins/slideshow-jquery-image-gallery/

  2. jeffrod
    Member
    Posted 1 year ago #

    I suspect that this won't get a ton of attention so maybe a solution would be to provide a built-in alternate transition for IE8 browsers? Or maybe you can just provide a hook into the JavaScript so I can manually take control of the transition and selectively serve a hardcoded transition to IE8?

  3. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Jeff,

    Thanks for reporting this behaviour. The video makes it very clear, it's great that you included it. I'll have a look at it tomorrow and I'll try to resolve the problem in the release of version 2.2.11.

    Best regards,
    Stefan

  4. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Jeff,

    I have been able to reproduce the bug, but I haven't been able to resolve it yet. The bug has been placed on the project board and I'm hoping to resolve it next week.

    I'm sorry for the inconvenience.

    Best regards,
    Stefan

  5. jeffrod
    Member
    Posted 1 year ago #

    Thanks Stephan. I worked around the issue for now by modifying your source code and adding an additional event that was triggered at the end of the slide transitions. I handled that event and used my custom handler to force IE 8 to take a regular Fade transition.

    I can try to push that to your repo if you have that capability.

  6. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    Very nice! I'm hoping I'll be able to fix the issue before it will be necessary to force IE8 into using the regular fade option. I'll let you know how it's coming.

  7. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    Internet Explorer appeared to have some trouble displaying the slideshow with an automatic z-index when the slideshow was positioned absolute. Fixing it posed surprisingly easy, as the z-index simply needed to be set to 0.

    I've released the fix in version 2.2.11.

  8. jeffrod
    Member
    Posted 1 year ago #

    Great! I'm glad it was an easy and quick fix!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.