WordPress.org

Ready to get started?Download WordPress

Forums

Copyright Proof
[resolved] digiprove notices on my post right after short code from "short code UI" (13 posts)

  1. golfy
    Member
    Posted 1 year ago #

    Hi is there any way to fix this so the notice only appears once at the bottom of my screen instead of appearing several times, after every shortcode by shortcode ui plugin?

    thanks for looking into this.

    http://wordpress.org/extend/plugins/digiproveblog/

  2. DigiproveDevelopment
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Golfy,

    Without seeing your site I can't be sure but there are some settings that you can use:

    Go to "Settings" / "Copyright Proof", then click on the "Advanced" tab, you will see 2 relevant settings:

    "Show notice on multi-post web-pages:" - un-tick this
    " Show generic Digiprove notice in footer:" - tick this

    To specify whether you want Digiprove your Shortcodes, click on the on the Certifying Content tab, tick or untick the Short Codes box under "Select Post Types to be Digiproved:"

    Hope this gives you what you want.

    Regards
    Gerry

  3. golfy
    Member
    Posted 1 year ago #

    hi this is my site http://ataslaunch.com/the-maisons/, i've followed your instructions but it's still showing up with multiple notices.

    pls can you have a look please? thank you.

    done this
    "Show notice on multi-post web-pages:" - un-tick this - done
    " Show generic Digiprove notice in footer:" - tick this - done
    untick the Short Codes under "Select Post Types to be Digiproved:" - done

  4. DigiproveDevelopment
    Member
    Plugin Author

    Posted 1 year ago #

    That looks like an amazing place!!! I was in Singapore a few times I loved it.

    I'm not too familiar with the shortcode plugin, but it seems to be generating a lot of extra empty lines. Can you try one more thing - Edit each of the Shortcodes and go to the Copyright / Licensing panel (you'll have to scroll down to find it), then in that panel select No for "Digiprove this Shortcode:"

    Maybe that will work for you.

    Regards
    Cian

  5. golfy
    Member
    Posted 1 year ago #

    Glad you like it here Cian :-)

    Guess I have to find another way to work around this... Copyright / Licensing panel is not appearing in my shortcode ui editor....

  6. DigiproveDevelopment
    Member
    Plugin Author

    Posted 1 year ago #

    Golfy,

    Can I verify some assumptions with you - I tested here with Shortcodes UI version 1.9.1. I took a screenshot of the UI editor (https://www.dropbox.com/s/c7jsvjw3aw72y7j/Shortcodes%20UI.png), and the Copyright-Ownership-Licensing panel that I see (right at the very bottom of that same page) - https://www.dropbox.com/s/010bwcztu6io50i/Copyright-Ownership-Licensing%20panel.png.

    Did I install the correct shortcodes plugin? How do your screens differ from the attached screenshots?

    Regards
    Cian

  7. golfy
    Member
    Posted 1 year ago #

    i found it :-) realized i have to check Short Codes under "Select Post Types to be Digiproved:" for it to show up in the shortcode ui.

    i turn off digiprove for all my shortcodes but the notices are still showing up...

    are they showing up on your end?

  8. DigiproveDevelopment
    Member
    Plugin Author

    Posted 1 year ago #

    Golfy,

    That was well-spotted.

    The notices are gone at this end:-). Your browser cache probably just needs updating - press CTRL/F5 (if you are using windows).

    To ensure your visitors see the changes, make a small change to the text of the page.

    Regards
    Cian

  9. golfy
    Member
    Posted 1 year ago #

    hi cian, i actually switched it off the post as it was still populating with many many notices. unless u meant your end as in your testing?

  10. DigiproveDevelopment
    Member
    Plugin Author

    Posted 1 year ago #

    Golfy,

    We did some further testing here today. There is a conflict between the 2 plugins - the Digiprove notice is being appended to all Shortcode-UI-generated content if the post itself is Digiproved (whether the shortcode content itself was or not). This is triggered by some unexpected (by us) behaviour of the shortcode UI. Our testing shows that it does not occur with at least some other shortcode content plugins. In our next release we will handle this conflict.

    Your short-term solution options:
    - Use another shortcodes plugin (e.g. Shortcodes Pro) that does not conflict
    - Stop using Copyright Proof for posts that will have shortcodes in them

  11. DigiproveDevelopment
    Member
    Plugin Author

    Posted 1 year ago #

    Golfy,

    Just a quick update, the new release of Copyright Proof (2.13) contains a resolution for this issue.

    Cian

  12. golfy
    Member
    Posted 1 year ago #

    Tks Cian! works perfect now!

  13. DigiproveDevelopment
    Member
    Plugin Author

    Posted 1 year ago #

    Great. Thanks for pointing this out to us. Good luck with sales!

    Cian

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.