WordPress.org

Ready to get started?Download WordPress

Forums

Digg Digg
[resolved] Digg Digg not displaying at all (with W3TC) (5 posts)

  1. Hugh Grigg
    Member
    Posted 1 year ago #

    I've got Digg Digg set up on my site at http://eastasiastudent.net . It should be displaying on all posts, but doesn't display at all for non-logged-in users. That is, it only displays for logged in users (which is just me - I don't allow user registrations).

    I'm pretty sure this is to do with W3TC also being installed on the site. I've tried disabling W3TC, re-saving Digg Digg settings and re-enabling W3TC. No effect.

    To clarify, Digg Digg displays exactly how I want it for me if I'm logged in, it just doesn't display at all for anyone else who visits the the site.

    Would appreciate any ideas on how this might be fixed.

    http://wordpress.org/extend/plugins/digg-digg/

  2. Stephen Cronin
    Member
    Posted 1 year ago #

    I tweeted you this morning, but have now had a little more time to look into this. I was going to suggest you use the empty all caches button in W3TC because when I looked at this post:

    http://eastasiastudent.net/china/putonghua/wang-ruolin-dinner-three/

    the W3TC cached time was 2012-08-05 22:31:41, which is a few days ago. W3TC has an option to not show the cached version to logged in users, so I wondered if logged out users were seeing and older version of the page, cached before Digg Digg was installed.

    However, I've since seen another post with a date of today and Digg Digg wasn't showing.

    I added Digg Digg to my own site (now removed) and had no problems at all. I was using WordPress 3.4.1, Digg Digg 5.2.9 and W3TC 0.9.2.4. My Digg Digg setting were straight out of the box. W3TC settings are pretty complex, so it's hard to explain them!

    I did notice that your HTML seems to be minified, so I turned on Minification in W3TC, but I couldn't get it to work for some reason.

    I can tell you that my source has the following for Digg Digg: a call to a CSS file, a call to a JavaScript file and some markup. Your site has the markup, but not the call to the CSS file or the JavaScript file. They've been combined with other scripts / stylesheets as part of the W3TC minification.

    Some JavaScript files don't play well with minification / combination, so it may be worth turning off the minification. That'd be my main suggestion at the moment.

  3. Hugh Grigg
    Member
    Posted 1 year ago #

    Genius, that was the exact problem. Turned off minify in W3TC and it now works! Thanks a lot. :)

  4. Frederick Townes
    Member
    Posted 1 year ago #

    Ideally manual mode is used for this kind of case if combine only for auto mode won't work. Meanwhile an upcoming release will allow for exclusions in auto mode.

  5. English2Go
    Member
    Posted 1 year ago #

    Hi Frederick,

    I am pretty much a pure novice on WordPress, but I have been able to use W3TC and am having the same problem described. I tried turning off minify and putting it in manual and my site got all jumbled up. Any advice would be greatly appreciated.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic