WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
Digest sending time issue (13 posts)

  1. raybman
    Member
    Posted 2 years ago #

    Most of what this plugin does is great.

    However, there is an annoying design quirk that keeps messing up the Digest sending day/time every time I make a change to any of the settings.

    I have been trying to use the Weekly sending schedule for the Digest. When I save the settings, the day chosen changes to the day of saving the settings (in my case, a week ahead). For example, I have a setting saved to send on Friday, if I make a change to any other settings on Tuesday then Tuesday becomes the new day to send the weekly Digest (which ends up being a week from the day of saving the settings).

    I guess this is because when submitting the changes, it is saving all settings as of that moment on the settings page.

    I would be great if the Digest mailing time/day would stick no matter what other settings have been changed. Perhaps it would be better to have the sending time setting as an independent configuration section...or?

    Please inform me if there is something I am missing
    Ray

    Using version: 6.4

  2. mattyrob
    Member
    Plugin Author

    Posted 2 years ago #

    @raybman,

    I've got 6.4 running on one of my sites in Digest mode with WordPress 3.2.1.

    Provided I don't change the Digest frequency or the time in the drop down just below where it says "Send Digest Notification at" my Digest time stays the same.

    What settings are you changing that is resulting in the digest time begin updated?

    Also, what setting do you have under Settings->General - Timezone?

  3. raybman
    Member
    Posted 2 years ago #

    Some of the settings I changed were the notification settings and email template text.

    Settings->General - Timezone > Local time > Los Angeles

    Where is the time setting for the plugin saved? In the Database?

  4. mattyrob
    Member
    Plugin Author

    Posted 2 years ago #

    @raybman,

    The setting is stored in the Subscribe2 option setting array ($this->subscribe2_options['email_freq']). The code checks to see if the newly input setting is different from the stored one or if the hour is different from the scheduled time before making changes to the database entry though.

  5. raybman
    Member
    Posted 2 years ago #

    Thanks for the information on that setting. I was hoping there would be an easy way to override the saved date/time. Doing a weekly Digest, the setting has to be set a week in advance, on the day I want the Digest to be sent out.

    As for the other issue, now I am not seeing it happen anymore. I'm wondering if there wasn't a couple of times when I inadvertently made some keyboard tabs and/or mouse scrolling actions that triggered the time changes without realizing it.

    Thanks MattyRob

  6. mattyrob
    Member
    Plugin Author

    Posted 2 years ago #

    @raybman,

    Glad to hear the random changing issue is gone.

    If you want to edit the time of the weekly digest more than is allowed in the plugin currently I'd highly recommend WP-Crontrol. It allows you to edit the timings of scheduled cron jobs very easily.

  7. raybman
    Member
    Posted 2 years ago #

    I'll have to check that one out.

    Thanks for the advice.

  8. raybman
    Member
    Posted 2 years ago #

    MattyRob,

    No, I guess that was not the issue, because the issue is back.

    This morning (before 10am) I set the mail out time to 10am on Fridays, so the new setting would be next Friday, and all seemed to be set after saving.

    Later, I came back to the settings page at 10:30am (same day) and there was the new setting for Friday @ 5pm for the next mailing.

    And that is something else I noticed every time I come back to the settings page; the drop down time list always reverts to 5pm.

    I don't see anybody else mentioning this problem so I guess there is something unique about my set-up.

    My site Set-up:
    Server: LAMP (typical)
    WP: 3.2.1
    Plugins: AIOSEOP, Akismet, Block-Spam-By-Math-Reloaded, Block Bad Queries (BBQ), Fast Secure Contact Form, Google XML Sitemaps, Subscribe to Comments Reloaded, Tweet, Like, Google +1 and Share, WP-Mail-SMTP

    I did check into the Crontrol plugin, but I don't see how it will allow a time setting override.

    Anyway, maybe you can shed some light on the problem.

    Thanks...

  9. mattyrob
    Member
    Plugin Author

    Posted 2 years ago #

    @raybman,

    The difference in time is pretty close to the time difference between where you are in the World (LA) and UTC / GMT.

    Your WordPress blog is set to use the LA timezone but what time does your server think it is and what timezone is PHP using?

    Try the following PHP statements and see what they tell you:

    echo 'date_default_timezone_set: ' . date_default_timezone_get() . '<br />';
    echo date('l jS \of F Y h:i:s A');
  10. raybman
    Member
    Posted 2 years ago #

    The server time is set to US East coast time, so 3 hours ahead of LA.

  11. mattyrob
    Member
    Plugin Author

    Posted 2 years ago #

    @raybman,

    Something strange is going on that I can't future out as yet.

    If you still have WP-Crontrol installed and active go to Tools->Crontrol in the administration area and look for a scheduled job called s2_digest_cron.

    This page will tell you the date and time when the job is going to run and also how long it is from the current time until that task time. You can click on the word 'Edit" and change the date and time to your desired scheduled time.

  12. raybman
    Member
    Posted 2 years ago #

    Okay, I'll keep messing with it and see if I can find the issue/conflict or whatever the heck is making this happen.

    Otherwise, I really like the plugin since it does everything else well.

    I'll post if I find a solution.

    Thanks

  13. raybman
    Member
    Posted 2 years ago #

    Well, I seem to have identified what is causing the problem.

    My WP time-zone settings was set by city name, but when I use the UTC (UTC-7 for me) the Subscribe2 plugin maintains the correct digest sending time.

    Hope this helps anyone else that might have the same problem...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags