WordPress.org

Ready to get started?Download WordPress

Forums

Difficult to explain. (8 posts)

  1. kdknowles
    Member
    Posted 8 years ago #

    I'm having trouble with the URL to my blog site. I may have set it up wrong? I created a folder in the root ok my hosting account and install WP in that folder. then I set my hostheaders to that folder. Example: http://www.kdknowles.com points to root/www/kdknowles. Now when I go to http://www.kdknowles.com in a brwoser all is fine until I go to the dashboard then the URL goes changes from http://www.kdknowles.com/whatever to http://kdknowles.ehost-services102.com/kdknowles/wp-admin/. And to top it all off when I go into Manage>>Posts then try to go to the "next" page I get a 404 error. It's looking for http://www.kdknowles.com/kdknowles/wp-admin/edit.php?paged=2 which does not exist. I am totally at a loss. Any suggestions would be a great help.

  2. Michael Bishop

    Posted 8 years ago #

    I'm not seeing any problems. I tried a few links, including the "register", and all is fine from my end. YOu may want to check with your host about the directory structure.

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    I see his problems. Look at the links in the meta sidebar.

    kd: Have you set the wordpress and blog addresses in the Options panel correctly?

  4. Michael Bishop

    Posted 8 years ago #

    Hmm. That's odd. The register link in the sidebar is off, the register link in the post correct.

    You are probably correct in the URI and blog address assessment.

  5. kdknowles
    Member
    Posted 8 years ago #

    This is what I have set:

    WordPress address (URI): http://kdknowles.ehost-services102.com/kdknowles

    Blog address (URI): http://www.kdknowles.com

    Please note I am not a skilled web dev and have no PHP skills. After reading the docs it was my understanding that the WP address would be used internally and the Blog address would be what was displayed on the web. Appearently my understanding was incorrect. Can you set me straight?

    I did try to set the WP address to http://www.kdknowles.com but that broke the entire site lol I had to go into the DB and fix that.

    What am I doing wrong?

  6. kdknowles
    Member
    Posted 8 years ago #

    Correction: Blog address (URI): http://www.kdknowles.com

  7. kdknowles
    Member
    Posted 8 years ago #

    Oh the strips out the http :// hehe opps

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    No, unless you've done something really unusual, the site and blog addresses should be identical. If everything on your page is available through http://www.kdknowles.com, then that should be the content of both of them.

    I don't know why setting them the same would break the blog, except that your permalinks would be wrong until you updated them. Should just be able to delete the htaccess to get access to it and then update the permalinks to fix it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags