WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Different titles permalink (11 posts)

  1. ghoulsnghosts
    Member
    Posted 5 years ago #

    I've just installed 1.04 and everything works fine but titles sometimes have permalinks http://www.mydomain.com/?p=123 and sometimes http://www.mydomain.com/2009/05/sample-post/ (this is the permalink structure I use).

    Is there a way to force the use of the right permalink structure?

  2. Samuel B
    moderator
    Posted 5 years ago #

    just reset the permalinks
    admin - settings - permalinks
    sometimes servers get confused, too
    :>)

  3. ghoulsnghosts
    Member
    Posted 5 years ago #

    I tried twice, but the problem persists :-(
    Seems to be a bug
    Ideas?

  4. esmi
    Forum Moderator
    Posted 5 years ago #

    Make sure that you're not viewing old/cached pages in your browser. Clear your local cache or use CTRL-F5 to force a hard refresh.

  5. ghoulsnghosts
    Member
    Posted 5 years ago #

    I'm sure: checked 3 browsers with cache cleared.
    Permalinks work fine, titles don't.

  6. ghoulsnghosts
    Member
    Posted 5 years ago #

    this is a huge problem because search engines sees duplicate content.

    h2 titles keeps showing http://www.mydomain.com/?p=123 regardless of the permalinks settings :-(

    I'm sure this happens to every p2 1.04

    Can anyone help to fix it?

  7. esmi
    Forum Moderator
    Posted 5 years ago #

    Duplicate content is not a big problem and will not result in a Google penalty unless there is clear intent to deceive:

    http://googlewebmastercentral.blogspot.com/2008/09/demystifying-duplicate-content-penalty.html

    If it's still a problem, consider providing a Google sitemap. That will let Google know which URLs you prefer.

  8. ghoulsnghosts
    Member
    Posted 5 years ago #

    Thanks for the link :-)

    But can anyone fix it?

  9. ghoulsnghosts
    Member
    Posted 5 years ago #

    the problem is in functions.php at line 366

    http://pastebin.com/f234fa660

    shows guid for the titles instead of permalink.
    I'm not a programmer, how can I show permalink instead pf guid?

    TIA

  10. ghoulsnghosts
    Member
    Posted 5 years ago #

    here you'll find the fix
    http://pastebin.com/f51d2db54

    thanks to ansimation from #wordpress on freenode for the help :-)

  11. Zajda
    Member
    Posted 5 years ago #

    Thanks, it helped me :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags