WordPress.org

Ready to get started?Download WordPress

Forums

Different install error. Parse error: parse error, unexpected T_STRING in /home/ (9 posts)

  1. jessmina
    Member
    Posted 9 years ago #

    I get this error when trying to view my INSTALL.PHP file through the address bar. It is different to the error messages I've received before:

    Parse error: parse error, unexpected T_STRING in /home/jessmina/public_html/words/wp-config.php on line 4

    The text of my WP-CONFIG file is as follows (jessmina_ due to server default prefixing):

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'jessmina_wordpress); // The name of the database
    define('DB_USER', 'jessmina_jess'); // Your MySQL username
    define('DB_PASSWORD', 'mypassword'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    I'm also continuing to get the same error messages when viewing INSTALL.PHP through my FTP program:

    install.php
    File Type: PHP script text

    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file.");

    require_once('../wp-config.php');
    require_once('./upgrade-functions.php');

    $guessurl = str_replace('/wp-admin/install.php?step=2', '', 'http://' . $_SERVER['HTTP_HOST'] . dirname($_SERVER['PHP_SELF']) );

    if (isset($_GET['step']))
    $step = $_GET['step'];
    else
    $step = 0;
    header( 'Content-Type: text/html; charset=utf-8' );
    ?>

    ...plus more garble. I tried deleting my database, my username and all the wordpress folders/files from the server, then recreating a database with a different name and then changing WP-CONFIG to match it, then uploading the WordPress files all over again.

    But this made no difference, except it changed the error message I received when viewing INSTALL.PHP through the address bar.

    I also re-read the instructions. I placed UPGRADE-FUNCTIONS.PHP in the folder above INSTALL.PHP (because it seemed to want it there, according to the code) and WP-CONFIG.PHP in the WORDS folder. I seem to have done everything correctly, so I don't know what's going on.

    Any suggestions? I'm at my wit's end. I even tried emptying temporary files, the cache and history, to no avail!

  2. Basically, it means that you touched something that you shouldn't have.

    From what you have copied, it looks like you're missing a single quote at the end of jessmina_wordpress in the DB_NAME field.

    Just to be sure, open wp-config-sample.php in any of the "approved text" editors (word processors, like Microsoft Word, are not text editors): http://codex.wordpress.org/Glossary#Text_editor

    Now, input the correct data in the DB_NAME, DB_USER, DB_PASSWORD, and DB_HOST sections, be careful not to delete or replace those single quotes, you need them. Do not touch anything else.

    Save the file as wp-config.php and replace the copy of wp-config.php on your server with this new one.

  3. jessmina
    Member
    Posted 9 years ago #

    Oh my gosh, you are a genius! lol, it's so frustrating when it's the little things like that. It's actually (more or less) working now.

    At least this time, there are no big chunks of code. WordPress just has an issue with the database name now, but I guess I'll fiddle around and try inputting the names without prefixes, and see how it goes.

    Thank you so much!

  4. jessmina
    Member
    Posted 9 years ago #

    Now it can't find the database, but it accepts that the username is OK. It mentions the prefix thing as a possible solution, as well as to check whether the database actually exists. I checked this in MySQL. It exists on my server as jessmina_wordpress, but do I need to do anything else to "set the database up" before it can be found by INSTALL.PHP?

    Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the innerfai_wordpress database.

    * Are you sure it exists?
    * On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?

    If you don't know how to setup a database you should contact your host. If all else fails you may find help at the WordPress Support Forums.

  5. Beel
    Member
    Posted 9 years ago #

    Can't select "innerfai_wordpress"? But you say your database is "jessmina_wordpress" - set the correct database name in the config file.

  6. jessmina
    Member
    Posted 9 years ago #

    lol, sorry. I was mixing up the example names. It is actually jessmina that I've used both in CONFIG and the database name, that I can assure you. :) I'm thinking that perhaps I need to do something further to set up the database. Am I right?

  7. Possibly. Did you complete step 2 of the detailed installation instructions?

    http://codex.wordpress.org/Installing_WordPress#Step_2:_Create_the_Database_and_a_User

  8. jessmina
    Member
    Posted 9 years ago #

    I just contacted my host for support, and apparently (hidden away in the depths of the control panel) was an automated WordPress installation plugin. Which means that it's all working now. Thanks so much for your patience and your help. I bet I'll be back again sometime with more questions, but until then, thank you. :-)

  9. midget_666
    Member
    Posted 8 years ago #

    i get this error when i try to view my activate.php page through my address bar - Parse error: parse error, unexpected T_STRING in /home/chicken/public_html/vars.php on line 14.

    <?php
    //===========Your Sites Main Settings===========//

    //Purchase confirmation and site contact email address (this is never shown to members!):
    $private_sys_email = 'admin@yoursite.com';

    //Database host (localhost is your own domain):
    $db_host = 'localhost';

    //Database username:
    $db_user = 'chicken_chicken;

    //Database password:
    $db_pwd = 'xxxxx';

    //Database name:
    $db_name = 'chicken_chicken';

    //Site e-gold number - This is your site e-gold for receive upgrade money, change 1234567 to your e-gold
    $site_egold = '2419094';

    //Moneybookers email ID for receive Moneybookers payment. Replace admin@xxxxx.com with your moneybookers email
    $site_moneybookers = 'admin@xxxxx.com';

    //Stormpay email ID for receive StormPay payment. Replace xxxxx.com with your site name
    $site_stormpay = 'admin@chickensurf.com';

    //Admin panel - your admin control panel link, this for send email to yourself, no any member can get this info
    $admin_url = 'http://chickensurf.com/control/';

    //Main header root loaction:
    $m_header = $_SERVER['DOCUMENT_ROOT'] . '/autosurf/header.php';

    //Main footer root loaction:
    $m_footer = $_SERVER['DOCUMENT_ROOT'] . '/autosurf/footer.php';

    //Members header root loaction:
    $mem_header = $_SERVER['DOCUMENT_ROOT'] . '/autosurf/header.php';

    //Members footer root loaction:
    $mem_footer = $_SERVER['DOCUMENT_ROOT'] . '/autosurf/footer.php';

    //Members Menu:
    $mem_menu = 'memlinks.html';

    //Site URL:
    $self_url = 'http://www.chickensurf.com';

    //Site name for security checks:
    $self_name = 'http://www.chickensurf.com';

    //Default site to show when no valid user sites:
    $default_site = 'http://www.chickensurf.com';

    //Admin Control Panel URL
    $control_url = 'http://chickensurf.com/control/';

    //Site Title:
    $title = 'Chickensurf.com - Paid Auto Surf';

    //Name the Upgrade Credits (Do not include the " s " - Program will do this for you - i.e. Upgrade Credit or Upgrade Unit etc...):
    $upgrade_title = 'Upgrade Unit';

    //Site URL to Index.php - Leave out http:// and do not add a / at the end of the url:
    $siteurl = 'chickensurf.com';

    //==========Site Settings============//

    //Font Type
    $fontface = 'Verdana';

    //Admin Panel BG Color
    $admincolor = '#CCCCCC';

    //Button BG
    $adminbutton = '#CCCCCC';

    //Members Area Cell BG 1
    $cellbg1 = "#CCCCCC";

    //Members Area Cell Bg 2
    $cellbg2 = "#FFFFFF";

    //Surf bar timer text color:
    $timer_txt = "#000000";

    //Surf bar timer background color:
    $timer_bg = "#d3d3d3";

    //PTC bar timer text color:
    $ptctimertxtcolor = "#000000";

    //PTC bar timer background color:
    $ptctimerbg = "#FFFFFF";

    //Pages to surf before signup bonus credits given:
    $activation_pages = 5;

    //Surf bar height
    $bar_height = 90;

    //Allow random referrals for Paid members? yes = yes or no = no
    $allow_rand_refs = 'no';

    //Allow minimized viewing (0 = NO 1 = YES) ??
    $allow_mmax = 0;

    //Allow user validation of sites (0 = NO 1 = YES) ??
    $allow_site_validation = 0;

    //Cashout requests = 1 : Mass monthly Pay = 0 (0 = NO 1 = YES) ??
    $allow_cashout_requests = 1;

    //Allow member to upgrade their refs if they have enough funds (0 = NO 1 = YES) ??
    $allow_referral_upgrades = 1;

    //The amount of days (365 = 1 year, 0 = NEVER EXPIRES) an upgrade unit/credit is valid (from date of purchase):
    $max_invest_days = 15;

    //Credits to earn suring in one day before ROI awarded
    $min_credits_to_earn = 50;

    //Number of days to keep surf stats (0 = FOREVER):
    $keep_stats = 65;

    //Number of days to keep site hit stats (0 = FOREVER):
    $keep_site_stats = 7;

    //Number of days to keep referral page stats (0 = FOREVER):
    $keep_refpage_stats = 1;

    //Daily ROI if amount of credits above (i.e. if the above is 100 and below is 1, the ROI is 1% per 100 credits earned surfing in 1 day).
    $roi_conversion_ratio = 10;

    //Upgrade member to Upgraded Status if they use their earnings to buy at least 1 share (0 = NO 1 = YES) ??
    $upgrade_member_if_buy = 1;

    //Email Yourself (to the email address you enter at the top of this file) if a member purchases shares with personal earnings (0 = NO 1 = YES) ??
    $email_admin_if_buy = 1;

    //Email Yourself (to the email address you enter at the top of this file) when daily ROI is paid (0 = NO 1 = YES) ??
    $email_admin_when_roi = 1;

    //Payout Merchants (follow suit - "1" => "PayPal", "2" => "E-Gold" etc...):
    $payout_merchants = array("1" => "E-Gold", "2" => "StormPay");

    //Signup Special Note:
    $signup_special_note = "<font face=$fontface size=2><b><font color=red>Important:</font></b> Your site must not have any pop-up windows, must not break out of frames and must not use any forwarding or redirection!</font>";

    //Member Edit Page Special Note:
    $mem_edit_special_note = "<font face=$fontface size=2>Please ensure your payout details are correct!</font>";

    //Server Time:
    $server_clock = "<br><font face=\"$fontface\" size=1><b>Current Server Time:</b> " . date('F, j'.'S Y g:i:s'.'a') . "</font>";

    //Email headers
    $email_headers = "MIME-Version: 1.0\r\nContent-type: text/plain; charset=iso-8859-1\r\nFrom: \"$title Admin\" <noReply@YourSite.com>\r\nReply-To: \"NoReply\" <noreply@YourSite.com>\r\nX-Priority: 3\r\nX-Mailer: PHP 4\r\n";

    //Surf bar banner HTML:
    $surf_ban_rotator = "<script language='JavaScript' src='/banner.php?style=non_ssi'></script>";

    //Default Banner Details (for the ad rotator):
    $default_banner = "http://www.secure-invest.com/banner6.jpg";
    $default_link = "http://www.secure-invest.com";
    ?>

    if any one can help me it would be muchly appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic