WordPress.org

Ready to get started?Download WordPress

Forums

Pinterest RSS Widget
[resolved] Did WordPress 3.5 Break the Plugin? Mine doesn't seem to work anymore. (11 posts)

  1. EndTheTrendNow
    Member
    Posted 1 year ago #

    It doesn't seem to be loading since I installed WordPress 3.5.

    http://www.endthetrendnow.com. You can see it near the bottom.

    http://wordpress.org/extend/plugins/pinterest-rss-widget/

  2. EndTheTrendNow
    Member
    Posted 1 year ago #

    Yep it is definitely broken. Just tried it on another site where I had an older version of WP and just upgraded that one as well.

  3. bondjack
    Member
    Posted 1 year ago #

    hmmm same here. I saw that bkmacdaddy is looking for a new developer to help him maintaining this plugin. I hope this will be fixed.
    Bummer if it doensn't it is a great plugin.

  4. milah227
    Member
    Posted 1 year ago #

    Yes it broke on my page as well. None of the images are showing. I really hope it gets fixed as well! http://www.autumnorphey.com/gallery

  5. milah227
    Member
    Posted 1 year ago #

    Something is wrong with how the images are now inserted. If I look at the source code there's no link here img src="". So I'm trying to figure out how to get the post thumbnail now in the code. Just wanted to update you all. If I find the fix I'll post it here. I'll be working on this for the rest of the morning...lol. This is like the coolest plugin EVER! :)

  6. milah227
    Member
    Posted 1 year ago #

    With the update of how to create image galleries with wordpress 3.5 I've read you cannot "insert" an image anymore. I think the problem is here:

    if ($thumb = $item->get_item_tags(SIMPLEPIE_NAMESPACE_MEDIARSS, 'thumbnail') ) {
    $thumb = $thumb[0]['attribs']['']['url'];
    $content .= '<img src="'.$thumb.'"';
    $content .= '

  7. milah227
    Member
    Posted 1 year ago #

    OH MY I FIGURED IT OUT!! After searching and searching, some return value on one of their functions must have changed. Just delete the section of code below in the plugin file (pinterest-rss-widget/pinterest-rss-widget.php) and the images will show up again! YAHOO!!
    } else if ( $useenclosures == 'yes' && $enclosure = $item->get_enclosure() ) {
    $enclosure = $item->get_enclosures();
    $content .= '<img src="'.$enclosure[0]->get_link().'"';
    $content .= ' alt="'.$item->get_title().'"/>';

  8. EndTheTrendNow
    Member
    Posted 1 year ago #

    Milah227,

    That worked like a charm. Thanks for the information and finding a fix.

    1. Go To Plugins
    2. Click Edit for the Pinterest RSS Widget
    3. Search for "else if ( $useenclosures == 'yes' && $enclosure = $item->get_enclosure() ) {"
    4. Delete the code above that Milah227 specifies.

    Cheers

  9. bkmacdaddy
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the help and solution, Milah227. I will try to get the plugin code updated this week and the newest version in the WordPress repository so that no one will have to edit the code in the future. I really appreciate your assistance!

  10. deejayutz
    Member
    Posted 1 year ago #

    Thank you very much for the fix. The plugin is awesome !

  11. bkmacdaddy
    Member
    Plugin Author

    Posted 1 year ago #

    I've updated the plugin with the fix milah227 figured out. Please update and let me know if it resolves your issues. And thanks for the help, milah227!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.