WordPress.org

Ready to get started?Download WordPress

Forums

Diamond MultiSite plugin causing problems after upgrade to 3.2.1 (11 posts)

  1. andrewmowder
    Member
    Posted 2 years ago #

    I just did a manual upgrade to 3.2.1 (Multi Site) and everything seems to working fine except for Diamond MultiSite. When it's activated and I attempt to go to the homepage I get this error:

    PHP Warning: file_put_contents(C:\inetpub\wwwroot\wp-content\plugins\diamond-multisite-widgets/cache_recent-posts): failed to open stream: Permission denied in C:\inetpub\wwwroot\wp-content\plugins\diamond-multisite-widgets\diamond-cache.php on line 26
    PHP Warning: file_put_contents(C:\inetpub\wwwroot\wp-content\plugins\diamond-multisite-widgets/cache_recent-posts): failed to open stream: Permission denied in C:\inetpub\wwwroot\wp-content\plugins\diamond-multisite-widgets\diamond-cache.php on line 26
    PHP Warning: file_put_contents(C:\inetpub\wwwroot\wp-content\plugins\diamond-multisite-widgets/cache_recent-posts): failed to open stream: Permission denied in C:\inetpub\wwwroot\wp-content\plugins\diamond-multisite-widgets\diamond-cache.php on line 61
    PHP Warning: file_put_contents(C:\inetpub\wwwroot\wp-content\plugins\diamond-multisite-widgets/cache_recent-comments): failed to open stream: Permission denied in C:\inetpub\wwwroot\wp-content\plugins\diamond-multisite-widgets\diamond-cache.php on line 26
    PHP Warning: file_put_contents(C:\inetpub\wwwroot\wp-content\plugins\diamond-multisite-widgets/cache_recent-comments): failed to open stream: Permission denied in C:\inetpub\wwwroot\wp-content\plugins\diamond-multisite-widgets\diamond-cache.php on line 26
    PHP Warning: file_put_contents(C:\inetpub\wwwroot\wp-content\plugins\diamond-multisite-widgets/cache_recent-comments): failed to open stream: Permission denied in C:\inetpub\wwwroot\wp-content\plugins\diamond-multisite-widgets\diamond-cache.php on line 61

    I have verified that the plugin exists and that it is in the correct place.

    Anyone have any ideas?

  2. Did you turn off the plugin and try turning it back on?

  3. andrewmowder
    Member
    Posted 2 years ago #

    Yeah, I've de-activated/activated it quite a few times, deleted and re-installed it several times, and have even gone so far as to test it with just 'recent comments' active, with just 'recent posts' active etc. (I am placing these inside of the addw2p plugin on my homepage. This worked fine in 3.1.3 but hasn't worked since the manual upgrade to 3.2.1. Every page that doesn't contain the diamond multisite widget will work fine even when it's activated, but the homepage (the page it's on) will not. As soon as I de-activate it, the page comes back (sans plugin, of course).

  4. andrewmowder
    Member
    Posted 2 years ago #

    Also, possibly related - what is the diffence between plugins showing up in network admin vs. site admin? Most of my widgets are in network admin, but a couple of them are showing up in site admin.

  5. andrewmowder
    Member
    Posted 2 years ago #

    Ipstenu,

    I think I've partially figured out the issue. I think it is some sort of caching issue. When I remove the diamond multisite plugin (manually) it still shows in the admin area and allows me to mess with the settings. When I add it into addw2p it will show that it's there, but of course when I visit the homepage it is not there (albeit the page DOES display. The error messages (above in my first post) that display when the plugin is installed in the directory shows, for example:

    \wp-content\plugins\diamond-multisite-widgets\diamond-cache.php on line 26

    Note the 'diamond-cache.php' portion of that. Do you know where WordPress is saving the settings for a removed plugin, and how to delete/reset that?

    I think maybe I'm on the right track here, but maybe not...

    Thank you in advance,

    Andrew

  6. Usually that resets if you go into the wp-admin/plugins page. Did you delete the plugin folder?

  7. andrewmowder
    Member
    Posted 2 years ago #

    yeah, I've tried that. I forgot to mention before that I'm running IIS 7 on Windows. Perhaps it's just not compatible with that + WP 3.2.1.

    Do you happen to know of any other plugins/combination of plugins that might take the place of Diamond MultiSite? I haven't much luck finding anything close.

  8. andrewmowder
    Member
    Posted 2 years ago #

    Follow up:

    I emailed the author. He suggested adding write permissions to the diamond-multisite-widgets directory for the IUSR account. We did this and it failed.

    It gets 'permission denied' on file_get_contents and file_put_contents functions.

    Any ideas?

  9. What level of write permissions did you add, and did you make sure to apply them to teh files as well?

    I moved servers and had it barf on me, until I set cache_recent-posts (the file) to 777.

  10. andrewmowder
    Member
    Posted 2 years ago #

    We applied write prilivages to the write directory and everything below it and still no luck.

  11. Being pedantic, check that file and make sure it's there with the appropriate permissions :) Sometimes a blanket apply misses things.

Topic Closed

This topic has been closed to new replies.

About this Topic