WordPress.org

Ready to get started?Download WordPress

Forums

developing theme.... Comments and moo.fx? (1 post)

  1. onechrisjones
    Member
    Posted 7 years ago #

    So i am having trouble loading my comments into an accordion-

    I got carried away doing stuff, and it did work at one time... but i changed something, cant seem to figure out why the comments won't show up.

    Here is the code i think i am having a problem with....

    <div class="stretch" id="feedback">
          <h2 id="comments">
            <?php comments_number(__('No Comments'), __('1 Comment'), __('% Comments')); ?>
            <?php if ( comments_open() ) : ?>
            <a href="#postcomment" title="<?php _e("Leave a comment"); ?>">&raquo;</a>
            <?php endif; ?>
          </h2>
          <div class="stretcher"id="comments">
            <?php if ( !empty($post->post_password) && $_COOKIE['wp-postpass_' . COOKIEHASH] != $post->post_password) : ?>
            <p>
              <?php _e('Enter your password to view comments.'); ?>
            </p>
            <?php return; endif; ?>
            <ol id="commentlist">
              <?php foreach ($comments as $comment) : ?>
              <li id="comment-<?php comment_ID() ?>">
                <?php comment_text() ?>
                <p><cite>
                  <?php comment_type(__('Comment'), __('Trackback'), __('Pingback')); ?>
                  <?php _e('by'); ?>
                  <?php comment_author_link() ?>
                  —
                  <?php comment_date() ?>
                  @ <a href="#comment-<?php comment_ID() ?>">
                  <?php comment_time() ?>
                  </a></cite>
                  <?php edit_comment_link(__("Edit This"), ' |'); ?>
                </p>
              </li>
              <br />
              <?php endforeach; ?>
            </ol>
            <br />
            <br />
            <?php if ( comments_open() ) : ?>
            <h2 id="postcomment">
              <?php _e('Leave a comment'); ?>
            </h2>
            <?php if ( get_option('comment_registration') && !$user_ID ) : ?>
            <p>You must be <a href="<?php echo get_option('siteurl'); ?>/wp-login.php?redirect_to=<?php the_permalink(); ?>">logged in</a> to post a comment.</p>
            <?php else : ?>
            <form action="<?php echo get_option('siteurl'); ?>/wp-comments-post.php" method="post" id="commentform">
              <?php if ( $user_ID ) : ?>
              <p>Logged in as <a href="<?php echo get_option('siteurl'); ?>/wp-admin/profile.php"><?php echo $user_identity; ?></a>. <a href="<?php echo get_option('siteurl'); ?>/wp-login.php?action=logout" title="<?php _e('Log out of this account') ?>">Logout &raquo;</a></p>
              <?php else : ?>
              <p>

    My problem is that the comments (when there are comments) won't show up in the box.

    I don't know how else to describe it....
    you can check it out @ http://www.chrisandevie.com/blog/?page_id=68

Topic Closed

This topic has been closed to new replies.

About this Topic