WordPress.org

Ready to get started?Download WordPress

Forums

desperately need some help! website displaying index of / (21 posts)

  1. kieranfivestars
    Member
    Posted 1 year ago #

    Hello,

    I'v been loking for days now, tried a million different things and it's now making my brain explode.

    basically I made a wordpress site, custom css thesis theme and all that, bought a domain and hosting package, using filezilla 2 for mac, and it wont work. I think I'm just missing a tiny detail as I can see what I've got, but its just displaying index of/ and all my files..

    website: http://www.kieranfivestars.com

    directory is public_html/all the files from my website, wp-content ect..

    I have an idea of what I'm doing :P don't get me wrong, but some things are just completely beyond me, would really appreciate some interest, thank you.

  2. jonradio
    Member
    Posted 1 year ago #

    The index.php file is missing.

    If one file is missing, it would be wise to be sure if any other files are also missing.

  3. kieranfivestars
    Member
    Posted 1 year ago #

    oh ok, well how do i go about amending this?

    Thank you

  4. kieranfivestars
    Member
    Posted 1 year ago #

    ok so I downloaded wordpress folder again from the site and copied over index.php but all it has inside it is..

    <?php
    /**
    * Front to the WordPress application. This file doesn't do anything, but loads
    * wp-blog-header.php which does and tells WordPress to load the theme.
    *
    * @package WordPress
    */

    /**
    * Tells WordPress to load the WordPress theme and output it.
    *
    * @var bool
    */
    define('WP_USE_THEMES', true);

    /** Loads the WordPress Environment and Template */
    require('./wp-blog-header.php');

    What do I need to write in here to get my site to work? Thank you

  5. jonradio
    Member
    Posted 1 year ago #

    The index.php file is correct as it is.

    Looking at your site now, it appears as if your wp-config.php file may have some incorrect values, as there is a Database Connection error.
    http://codex.wordpress.org/Editing_wp-config.php

  6. kieranfivestars
    Member
    Posted 1 year ago #

    So I need the database name, user, pass, host

    is the user name and password the one i used when going into http://www.mywebsite/wp-login.php?

    how do I find out the exact database name and host? is my host http://ftp.mywebsite.com?

    thank you for your responses

  7. govpatel
    Member
    Posted 1 year ago #

    So I need the database name, user, pass, host

    is the user name and password the one i used when going into http://www.mywebsite/wp-login.php?

    how do I find out the exact database name and host? is my host

    NO the database user name password are what set when you created the database you will need to log on server or ask your host to help you.

  8. kieranfivestars
    Member
    Posted 1 year ago #

    hmm ok so yeah I have an email off them stating username and password I got that, and i have put that in wp-config, but what excactly is DB_HOST and DB_USER?

    thank you

  9. kieranfivestars
    Member
    Posted 1 year ago #

    also do I have to export mysql from wordpress? or make one in cpanel? I'm so confused lol.

    anyone have an example of what there wp-config file looks like?

    thank you

  10. kieranfivestars
    Member
    Posted 1 year ago #

    now its telling me to install wordpress?? http://www.kieranfivestars.com

  11. govpatel
    Member
    Posted 1 year ago #

    You still do not have right database info in your wp-config.php so database can not connect you need recheck.
    Who is your host?

  12. kieranfivestars
    Member
    Posted 1 year ago #

    i have entered db-name, user, and pass correctly I think, i'v used the info from my sql section in cpanel, i have the db_host as 'localhost'

    and http://www.ukwebhosting.com/

    thank you

  13. govpatel
    Member
    Posted 1 year ago #

    I need to check with your host as I am getting this

    The connection has timed out

    The server at http://www.kieranfivestars.com is taking too long to respond.

    The site could be temporarily unavailable or too busy. Try again in a few
    moments.
    If you are unable to load any pages, check your computer's network
    connection.
    If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.

  14. kieranfivestars
    Member
    Posted 1 year ago #

    yeahh me too :/

    question tho, does my user and password in filezilla have to be the same as my MySql in cpanel?

    and is the username and pass in MySql database the one you put inside wp-config?

    can you understand what I am trying to ask here? thank you.

  15. govpatel
    Member
    Posted 1 year ago #

    They do not have be same your ftp username and password are set when you create your host account most likely will same as your host account.

    Database user name password are set when you create the database.

    WordPress user name and password are set when you install wordpress.

  16. kieranfivestars
    Member
    Posted 1 year ago #

    oh right ok, well I have all of this information, but it's now saying unable to connect and it has http://www.mywebsite.com:8888 at the end? this is what I use when connect to my website locally using MAMP localhost:8888 so I don't know what this means?

  17. govpatel
    Member
    Posted 1 year ago #

    Ok so you are trying to install wordpress on Mamp and not a online host.
    You will instructions here
    http://codex.wordpress.org/Installing_WordPress_Locally_on_Your_Mac_With_MAMP

  18. kieranfivestars
    Member
    Posted 1 year ago #

    no It works fine on Mamp, i now have a hosting service and it wont work lol, what im saying is its directing my site adress to http://www.mysite,com:8888

    and the 8888 is what I used to use on the end of my localhost adress localhost:8888

    my website should be up and running on http://www.kieranfivestars.com

    thanks

  19. govpatel
    Member
    Posted 1 year ago #

    ok you need change the urls in settings>>>General and since you can not log in dashboard you need to use one of this method
    http://codex.wordpress.org/Changing_The_Site_URL
    if you prefer to see video here

  20. kieranfivestars
    Member
    Posted 1 year ago #

    I have done it now :D thank you so much for responding govpatel and jonradio appreciate it so much, I had to go into phpadmin and change the www. from local host to http://mywebsite.com and a bunch of other stuff but I got there in the end, I can now stop pulling my hair out :P

    [ redacted, support is offered via the forum and not email ]

    and my website is http://www.kieranfivestars.com

  21. prionkor
    Member
    Posted 1 year ago #

    Close this as resolved

Topic Closed

This topic has been closed to new replies.

About this Topic