WordPress.org

Ready to get started?Download WordPress

Forums

Desperate for help!-- broken permalinks (6 posts)

  1. Sokb
    Member
    Posted 7 years ago #

    I posted this up yesterday and haven't received any suggestions for help so I am trying again. I'm very worried about the broken links and I am completely stuck for solutions.

    The site gets a fair amount of traffic during the week and I'm schedule to do another mass mailing in the next couple of days which always drives up more visitors. It's quite important I find a way of resolving this as quickly as possible.

    If you aren't able to help, please can you suggest alternative forums where people might be able to assist.

    This is what I posted up yesterday: I've marked it resolved and am trying again here.

    I think I've broken my permalinks. I would really appreciate some help. This is a link to the blog: http://www.sokwanele.com/thisiszimbabwe

    This is what I did:

    I tried to create a page titled 'Archives'. This is turn generated a link to the page as follows:

    http://www.---.com/thisiszimbabwe/archives

    I had FORGOTTEN that the custom permalink structure for the site was already set to be :

    http://www.---.com/thisiszimbabwe/archives/pageID

    I then deleted the page I created called 'archives', but the permalinks for all the pages are still going to the Error 404 page.

    I've tried updating the permalinks under options and it doesn't do anything.

    It's as if each link is now looking for a page that doesn't exist? Which is odd, because that page didn't ever exist before today and the permalinks worked fine.

    Have I created a database conflict somewhere? How do I resolve this?

    I would very much appreciate some assistance.

  2. thelazygeisha
    Member
    Posted 7 years ago #

    I had a similiar issue - ask your host to inspect your .htaccess file. WordPress makes some changed to the .htaccess involving redirects. Some others have had issues with this in trying to generate 404 errors, but when I modified my own .htaccess to turn off this new redirect, I also broke every link on my site. When I went back to it, the problem was fixed. I'm not sure exactly how or why this is happening, maybe someone with more of a clue can jump in, but it seems to be some kind of relationship between permalink structure and the .htaccess file & redirects.

    - nina

  3. Chris_K
    Member
    Posted 7 years ago #

    It sounds like .htaccess isn't getting updated. There are some troubleshooting tips at the Permalinks page to glance at.

  4. Sokb
    Member
    Posted 7 years ago #

    Thanks for the replies. I uploaded an older version of the .htaccess file to the server, overwriting the one that might be causing the issue and it seemed to work - for a second.

    All the permalinks started working as they should.

    But I then went into the admin side of WordPress and clicked on the Permalink tab under options. I did nothing more then that (didn't try to update links).

    When I went back to the site itself, the problem had returned.

    WP seems to have set the .htaccess file back to a default.

    We then put up the working version again and set to chmod 444 so no-one can write over the file. OK, this is a fix, but a bit of a work-around. Any other suggestions?

  5. Sokb
    Member
    Posted 7 years ago #

    ... actually, just spotted after posting the previous entry that the 'email this to a friend' option has stopped working now. So, still basically looking for a fix. Will try reinstalling the plugin and see if that helps.

  6. Sokb
    Member
    Posted 7 years ago #

    It's two weeks later .... we've still not managed to resolve our .htaccess problems. The workaround is holding it together but has disabled some fairly key features (as above)

    Our host is trying to help as as well.

    Does anyone have any experience of this or advice to share?

    Many thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic