WordPress.org

Ready to get started?Download WordPress

Forums

Deseprately need help ASAP, how to get gallery pic (11 posts)

  1. crystalsignature
    Member
    Posted 4 years ago #

    Hi folks,

    I hope I can get someone help me to solve this problem right away:

    I am using Epsilon theme, which has a slide to display pictures, in my site: http://www.crystalsignature.com , the picture can not be displayed. After spent hours on this, I believe a php file called glide.php is causing the problem, and in the file, the following code has bug:

    <?php the_excerpt(); ?>
    <?php $gallery = get_post_meta($post->ID, 'gallery', $single = true); ?>
    <img src="<?php bloginfo('stylesheet_directory'); ?>/timthumb.php?src=<?php echo $gallery; ?>&h=150&w=280&zc=1" alt=""/>

    The picture's URL is
    http://crystalsignature.com/wp-content/uploads/2009/04/p1050851.jpg

    The code is supposed to retrieve the URL and generate another URL for img src:
    http://www.crystalsignature.com/wp-content/themes/epsilon/epsilon/timthumb.php?src=http://crystalsignature.com/wp-content/uploads/2009/04/p1050851.jpg&h=150&w=280&zc=1

    Problem is $gallery returns nothing. What's wrong with the code? How can I fix it?

    Thank you very much.

  2. kmessinger
    Volunteer Moderator
    Posted 4 years ago #

    Have you checked Epsilon theme's site? WP cannot help with non WP errors.

    Also, normal debugging - turn all your plugins off and restore them one by one checking to see if the problem is fixed.

  3. Mark / t31os
    Moderator
    Posted 4 years ago #

    $gallery refers to a custom field called 'gallery'...

    Can we assume you have this custom field and you are entering a value.

  4. crystalsignature
    Member
    Posted 4 years ago #

    To kmessinger:

    I have checked Epsilon's site numerous time, and tried all the suggestions I found there with none of them work for my case. I also just tried debugging by disable plugin and re-enable it one by one, no use. Actually the theme's slide part (which is the most important one to me) is not working since the first time it is installed. :( too bad, eh?

    To: t31os_:

    $gallery refers to a custom field called 'gallery'...
    Can we assume you have this custom field and you are entering a value.

    I am very new to WordPress, although I do lots of asp.net programming, but I have no experience on php. What do you mean custom field? where can I see all my custom fields? I have been guessing is it something related to my category setting, can you be more specific?

    Thanks to everyone who viewed and responded my post.

    http://www.crystalsignature.com/

  5. crystalsignature
    Member
    Posted 4 years ago #

    Hi guys,

    Just an update, I can't endure the Epsilon problem so I switched to another theme, unfortunately there is a very similar problem (but I still like the new theme) since the two themes are from the same company

    So if you go to my site: http://www.crystalsignature.com/ you will see a different look and feel, in case anyone has visited my site before.

    Same problem, as you can see on the slide, there is a shite block, where it is supposed to be a picture.

    Thanks.

  6. kmessinger
    Volunteer Moderator
    Posted 4 years ago #

    Somthing is wrong with this photo, http://www.crystalsignature.com/wp-content/themes/primus/primus/timthumb.php?src=&h=120&w=250&zc=1

    The other photo works fine but the missing one is maybe not a jpg or maybe cmyk and not rgb? Check out the photo itself.

  7. Mark / t31os
    Moderator
    Posted 4 years ago #

    $gallery refers to a custom field called 'gallery'...
    Can we assume you have this custom field and you are entering a value.

    I am very new to WordPress, although I do lots of asp.net programming, but I have no experience on php. What do you mean custom field? where can I see all my custom fields? I have been guessing is it something related to my category setting, can you be more specific?

    Ordinarily a custom field is an option with a post or page. Just below the content area is the custom field box.
    http://codex.wordpress.org/Using_Custom_Fields

  8. t31os
    Member
    Posted 4 years ago #

    Furthermore, if adding the custom field does not resolve the problem (which i imagine it could very well be), please post the code from the aforementioned file.

    (timthumb.php)..

  9. djalbani
    Member
    Posted 4 years ago #

    You don't have permission to access /wp-content/themes/zherald/timthumb.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at buyfitflops.net Port 80

    Hi,

    I always get this error when I try to copy the link and reopen it in another browser tab of the black boxes where the picture should appear as thumbnails.....

    I need this help please help me, I am finding this from a very long time

    Email me at [ email redacted ]

  10. Mark / t31os
    Moderator
    Posted 4 years ago #

    To quote myself.... :-s

    Furthermore, if adding the custom field does not resolve the problem (which i imagine it could very well be), please post the code from the aforementioned file.

    (timthumb.php)..

    Which requires opening that file (not navigating to it in your browser) then copying and pasting the code from that file...

    The WordPress editor or an FTP program is suitable for getting to that files code.

  11. roxanarodrigue
    Member
    Posted 4 years ago #

    Here is the code of the timthumb.php

    [ Timthumb source removed. ]

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.