WordPress.org

Ready to get started?Download WordPress

Forums

Bad Behavior
Deprecated method call with WP 3.6 (9 posts)

  1. useStrict
    Member
    Posted 8 months ago #

    While reviewing this plugin, I found the following error and notice when installing (WP_DEBUG is turned on).

    Notice: wpdb::escape is deprecated since version 3.6! Use wpdb::prepare() or esc_sql() instead. in /Volumes/sitesell-dev/Wordpress/wordpress/wp-includes/functions.php on line 2875

    and

    The plugin generated 198 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    http://wordpress.org/plugins/bad-behavior/

  2. Tom Belknap
    Member
    Posted 5 months ago #

    ::bump::

    I'm definitely seeing the first error notice on debug mode, but cannot reproduce the second. Currently using WP 3.7.1.

    Love the plugin, though, been using it for years. Thanks!

  3. WPyogi
    Volunteer Moderator
    Posted 5 months ago #

    @Tom Belknap - this thread references WP3.6. Also have you seen:

    http://wordpress.org/support/topic/howto-report-problems-with-bad-behavior?replies=5

  4. clwill
    Member
    Posted 5 months ago #

    BUMP. Still seeing this.

    Yes, I've tried to report a bug, but the email address bounces, and attempts to create a login to log the bug also fail.

  5. Tom Belknap
    Member
    Posted 5 months ago #

    This should seriously not be a big fix. I'd be happy to do it, if I thought it would be received.

  6. WPyogi
    Volunteer Moderator
    Posted 5 months ago #

    We have no more info than you do, sorry. If a plugin author doesn't opt to update it, there's nothing WordPress.ORG can do.

    If you really want the plugin, you could consider hiring someone to look at it for you.

  7. Tom Belknap
    Member
    Posted 5 months ago #

    Good lord. This is the support thread for the plugin. Isn't that what WordPress set these things up to do? There's no real need for you to respond, the plugin owner should have done so.

  8. WPyogi
    Volunteer Moderator
    Posted 5 months ago #

    I was responding to the "BUMP" above - as your post was caught in the spam filter and I'd not seen it. Bumps and posting in multiple threads get moderators' attention - http://codex.wordpress.org/Forum_Welcome#No_Bumping

    If you want to fix it, sounds like other people would be pleased.

  9. clwill
    Member
    Posted 4 months ago #

    I did posted different info in two threads. I posted once in here to note that this is still an issue. And when pointed to the "how to report a bug in BB" thread, I posted in there to note that I couldn't report a bug as described.

Reply

You must log in to post.

About this Plugin

About this Topic