WordPress.org

Ready to get started?Download WordPress

Forums

Polldaddy Polls & Ratings
[resolved] Deprecated code (5 posts)

  1. Till Krüss
    Member
    Posted 10 months ago #

    I'm getting a few deprecated calls:

    Deprecated: Assigning the return value of new by reference is deprecated in /polldaddy/polldaddy-xml.php on line 743

    Notice: attribute_escape is <strong>deprecated</strong> since version 2.8! Use esc_attr() instead.

    http://wordpress.org/extend/plugins/polldaddy/

  2. Till Krüss
    Member
    Posted 10 months ago #

    I made a patch that fixes the deprecated function calls, removed the PHP4 idiom, prevented another undefined variable notice and fixed a few visual glitches: http://cl.ly/code/4112171Q3q1S

  3. Donncha O Caoimh
    Member
    Plugin Author

    Posted 10 months ago #

    Thanks @Till, fixing those has been on the todo list for quite some time!

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 10 months ago #

    And I've just checked those most of those changes into trunk. I've left the CSS ones as I have to investigate what each one does.

    Hopefully we'll get a new release out this week. Thanks for your help!

  5. Till Krüss
    Member
    Posted 10 months ago #

    The CSS changes are based on WP 3.6 and are: 1) hide #wpfooter and adjust margins in iframe/popup 2) corrected visual glitches of the answer options in the "save" meta box 3) removed fixed height of the "poll style" box

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.