WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
deployment creates blank pages (7 posts)

  1. jkd77
    Member
    Posted 1 year ago #

    I've setup w3 total cache using settings that have been successful on my hosting environment (Dreamhost) in the past. It seemed to setup fine when checking the site in the initial browser (for example Chrome), but then subsequent tests in other browsers (just to check caching - I don't think it's browser specific) fail and only show a blank page with zero code. My error log (wp-content/debug.log) doesn't seem to show anything useful. I enabled w3 Cache Debug, and those results are here (debug log made via Chrome when not logged in - please view the source to see the comments): http://bit.ly/WrODlw

    Here are the general settings I'm using:
    Page Cache: Disk Basic
    Minify: Disabled (Using BWP-Minify - seems to work ok)
    Database Cache: Disk
    Object Cache: Disk
    Browser Cache: Enable

    Thoughts? Any help would be greatly appreciated!

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    When you turned on W3TC, did it update your .htaccess? I took a look and it just has the standard WP lines.

  3. jkd77
    Member
    Posted 1 year ago #

    I thought it had changed htaccess. But I had to deactivate the plugin. Would deactivation erase those htaccess edits?

  4. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    It shouldn't.

    If you reactivate it, go make sure it puts the htaccess lines in. That could easily cause that problem :)

    The other possibility is you have a plugin conflict.

  5. bheadrick
    Member
    Posted 1 year ago #

    It probably isn't relevant to this specific problem, but I would disable db cache and object cache.

    I've had this same problem before, and it turned out to be an error in the htaccess file - as in, the plugin had updated it, but it had a mistake somewhere.

    Even after correcting the problem, page caching didn't work on this specific site I was using it on. I assume it had something to do with the theme being used.

    In that circumstance, I ended up using Quick cache for page caching. It does a bit better job at automatically updating the page cache when content is updated without having to completely clear the page cache.

  6. jkd77
    Member
    Posted 1 year ago #

    @bheadrick: took your advice and installed Quick Cache. Appears to be working though it hasn't been updated for around a year.

    @Mika E.: the .htaccess file appears to not have retained edits when plugin was deactivated. (Although I might have replaced it with a backed up version - I can't recall at this moment.) Unfortunately I don't have the time to devote to tracking down this issue presently - which is a shame since w3 cache has so much to offer.

    Thanks all!

  7. bheadrick
    Member
    Posted 1 year ago #

    still, 1yr is still more recent than w3tc.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic