WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] Deploy server code 200 again (4 posts)

  1. alex243
    Member
    Posted 8 months ago #

    Hi,

    I try to deploy my site, and installer started fine, but stopped on the step "#1 Deploy" with Error:
    ---------------------------------------------------------------
    server code: 200
    status: OK
    response:
    INSTALL ERROR!
    A wp-config.php already exists in this location. This error prevents users from accidentally overwriting the wrong directories contents. You have two options:
    Empty this root directory except for the package and installer and try again.
    Delete just the wp-config.php file and try again. This will over-write all other files in the directory.

    « Try Again

    ---------------------------------------------------------------------
    Follow the post: [server code: 200 - A wp-config.php already exists in this location]

    I commented 555-564 in installer.php :

    //MSG_ERR_ZIPMANUAL
    if ($_POST['zip_manual']) {
    if (!file_exists("wp-config.php") && !file_exists("database.sql")) {
    die(MSG_ERR_ZIPMANUAL . $back_link);
    }
    } else {
    //MSG_ERR_CONFIG_FOUND
    (!file_exists('wp-config.php')) or die(MSG_ERR_CONFIG_FOUND . $back_link);
    //MSG_ERR_ZIPNOTFOUND
    (is_readable("{$package_path}")) or die(MSG_ERR_ZIPNOTFOUND . $back_link);
    }

    But it didn't help and stopped again at Deploy step with error:

    Step 1: Files & Database

    Please try again an issue has occurred.
    server code: 0
    status: error
    response:

    The installer-log.txt is:
    UPDATED SCRIPTS: sql file: '/home3/addgloss/public_html/wpcd1108/installer-data.sql' wp-config: '/home3/addgloss/public_html/wpcd1108/wp-config.php' SECTION RUNTIME: 248.9203 sec.
    ****************************************************************
    DATABASE-ROUTINES
    ****************************************************************
    --------------------------------------
    SERVER ENVIROMENT
    ---------------------
    MYSQL VERSION: 5.5.32-cll
    TIMEOUT:5000
    MAXPACK:33554432
    --------------------------------
    DATABASE RESULTS
    ----------------------------------
    ERRORS FOUND:
    0
    DROP TABLE: removed (0) tables
    QUERIES RAN:3986
    wp_commentmeta: (0)
    wp_comments: (7)
    wp_duplicator: (1)
    wp_links: (0)
    wp_options: (341)
    wp_postmeta: (2633)
    wp_posts: (517)
    wp_term_relationships: (25)
    wp_term_taxonomy: (208)
    wp_terms:(208)
    wp_usermeta: (31)
    wp_users: (1)
    Removed '146' cache/transient
    rows
    SECTION RUNTIME: 1.5021 sec.
    ********************************************
    STEP1 COMPLETE @ 11:46:30 - TOTAL
    RUNTIME: 250.4294 sec.
    *********************************************

    Thanks

    http://wordpress.org/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 8 months ago #

    Hey alex243,

    I think your package may be to large and your trying to move to much data checkout this link it might help:
    -> Browse to: http://lifeinthegrid.com/duplicator-faq
    -> Find section: "3. Troubleshoot=> TimeOut Issues"

    Hope that helps!

  3. alex243
    Member
    Posted 8 months ago #

    Thanks for reply,

    I used Manual Extraction first
    (Installer --> How do I do a 'Manual Extraction'?) and it solved the problem.

    Thanks again

    Nice plugin!
    Alex

  4. Cory Lamle
    Member
    Plugin Author

    Posted 8 months ago #

    Excellent! Thanks for posting your update...

Reply

You must log in to post.

About this Plugin

About this Topic