WordPress.org

Ready to get started?Download WordPress

Forums

Deletes embed code on upload. (11 posts)

  1. cream007
    Member
    Posted 2 years ago #

    I go to post a music player embed and when I hit upload,the player flashes up and then disappears right as it posts. I click edit and the embed code is gone. Pls help

  2. theotherlebowski
    Member
    Posted 2 years ago #

    where's the embed player from?

    if you're embedding a player from another site then you don't need to upload anything, just copy and paste the embed code for the player into the post or page text area and wordpress does the rest.

  3. cream007
    Member
    Posted 2 years ago #

    I am uploading from another site and when I copy and paste the code, it is deleted everytime I upload? Is because I'm using the mobile app?

  4. theotherlebowski
    Member
    Posted 2 years ago #

    the key thing is you don't need to upload anything if you're embedding a player form somewhere like soundcloud.com you just need to copy and paste.

    at the site where that has the player there should be a share option. click it and get the embed code (it'll probably highlight when you click on it and click Ctrl + C (Cmd + C) to copy this code.

    go to your wordpress site, create a new post of page, in the post or page editor screen switch to HTML editor view and just paste the embed code in there. save the post or page and then publish it to view the play.

    you don't upload anything!

  5. cream007
    Member
    Posted 2 years ago #

    I am jus copy & pasting the code and when I hit post it gets removed somehow. I'm not uploading anything and the only options I have in the editor view is "visual" & "text". No html

  6. theotherlebowski
    Member
    Posted 2 years ago #

    where are you getting the player from?

  7. theotherlebowski
    Member
    Posted 2 years ago #

    also. which version of wordpress are you using?

  8. cream007
    Member
    Posted 2 years ago #

    I'm getting the player from Sharebeast.com (seen other WordPress blogs embed that player) and I'm using wordpress for Android 2.1.4

  9. theotherlebowski
    Member
    Posted 2 years ago #

    it may be that because it's an obscure service worpdress just doesn't like it... try embedding a soundcloud player and see if the actual process works. you'll need to publish the page to see the soundcloud palyer, it doesn't like appearing in previews!

  10. cream007
    Member
    Posted 2 years ago #

    It works perfectly with Soundcloud. Maybe I jus need to post the audio short code and url to make it work?

  11. theotherlebowski
    Member
    Posted 2 years ago #

    give it a try. it might be that it's a relatively new/obscure service more than anything else...

Topic Closed

This topic has been closed to new replies.

About this Topic