WordPress.org

Ready to get started?Download WordPress

Forums

Delete "Leave a Reply" (10 posts)

  1. sddonlon
    Member
    Posted 3 years ago #

    I'm a newbie to WordPress, and I prefer to use it as a CMS, rather than a blog. How do I turn off/delete the "Leave a Reply" box at the bottom of my pages???
    I've been searching everywhere, and not found a reliable solution yet.

    HELP!!
    -s

  2. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Have you disabled all commenting via Settings->Discussion?

  3. sddonlon
    Member
    Posted 3 years ago #

    Hi esmi,
    Yep, already done. I have a sneaking suspicion I have to delve into the .php. Please tell me it ain't so... !!

  4. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Sorry but it sounds as if you'll have to do some theme template editing. You'll need to look for, and remove <?php comments_popup_link();?>

  5. sddonlon
    Member
    Posted 3 years ago #

    Ok, cool. I'll get started and will let you know!
    Thanks so much for the fast response!!

  6. alchymyth
    The Sweeper & Moderator
    Posted 3 years ago #

    if you really don't want comments in pages, you can also remove <?php comments_template(); ?> together with the surrounding html tags from page.php.

    it is always a good idea to keep a backup copy of the original theme somewhere safe.

  7. mike72688
    Member
    Posted 3 years ago #

    I have this same desire, to remove the "Leave a Reply" box. But I don't have that code in my pages.php of the Twenty Ten 1.2. Here's mine:

    [code moderated according to forum rules - please use the pastebin]

    Any thoughts?

  8. STGMBC
    Member
    Posted 3 years ago #

    I am a fellow newbie

    it sounds like we had a similar question
    why dont you look at my post and the responces i received
    http://wordpress.org/support/topic/finetuning-a-site-and-removing-search-etc?replies=3#post-2064673

    why remove code when you can make it disappear altogther by a few simple tasks

  9. alchymyth
    The Sweeper & Moderator
    Posted 3 years ago #

    @mike72688

    try and look into loop-page.php;
    if that does not exist in your theme, look into loop.php - although this might also be used for single posts.

    make backup copies before editing

  10. mike72688
    Member
    Posted 3 years ago #

    Thanks. I got it. I made new pages, copied the content of the original page to the new page, deleted the old page, and renamed the new page. Fixed the problem. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags