WordPress.org

Ready to get started?Download WordPress

Forums

Definitive instructions for changing site url to remove ugly hosting domain name (5 posts)

  1. mikem42
    Member
    Posted 3 years ago #

    Hi, I have a site hosted with Network Solutions, which gave us the ugly URL "086478.netsolhost.com" for our WordPress installation. We have a proper domain name, which directs fine to the home page, but as soon as any link is clicked on, the ugly URL appears, and stays.

    I've been through dozens of pages on how to rename the site - looked at .htaccess, changing wp-config.php, editing the WordPress and Site Address fields in General Settings, editing the appropriate home and siteurl entries via wp_options in phpMyadmin - all of that good stuff.

    But nothing has worked so far. I've deleted cookies and cache to check each time what I should be seeing, but I either can't log back into the site or I get a range of generic error messages preventing me from getting access to the site.

    Is there a definitive set of instructions for what SHOULD be a fairly straightforward process? The domain is already pointing to the right place and the site otherwise works fine. I just want to get rid of the ugly URL.

    Thank you!

  2. Samuel B
    moderator
    Posted 3 years ago #

    you will need to use host's phpmyadmin to download a back up .sql file

    open this file in notepad or similar
    do a search and replace for crappy domain name -> good domain name
    upload file back to db

  3. mikem42
    Member
    Posted 3 years ago #

    Thank you Samuel - so is that more involved than the rewriting of the wp_options fields, 'home' and 'siteurl'? Should I also need to do anything in WordPress admin/general settings?

    Thanks so much again!

  4. Samuel B
    moderator
    Posted 3 years ago #

    yes - with multi site , the url's are stored in multiple locations

  5. mikem42
    Member
    Posted 3 years ago #

    HI again Samuel, I've just downloaded the full sql file, with Add Drop tables ticked, changed every occurrence of the ugly URL (there were several thousand) and imported the new file successfully. The site was fine, and I logged into admin again and the same ugly URLs were in General Settings, and looking back into the database again the details had all switched back also to the ugly URLs.

    I reimported the "clean" file again, this time not going near the browser but looking at the wp_options fields immediately after importing - and they were the ugly URLs again. Is there some way I'm not importing the sql file properly, despite the success message? I would have thought doing this with the database would clean it all out once and for all. Should I be clearing a cache somewhere or something like that, because I don't seem to have a wp-content/cache folder on the server.

    Really wracking my brains...

Topic Closed

This topic has been closed to new replies.

About this Topic