WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Default Tag Category isn't being applied.. (8 posts)

  1. silentmatt
    Member
    Posted 7 years ago #

    hey guys

    Ever since upgrading to 2.2, our default category doesn't seem to be applied... anyone else have this problem?

    It is properly selected under > Options > Writing, but doesn't actually appear when writing a new post...

    Anyone know where I should look to fix this?

  2. MichaelH
    Member
    Posted 7 years ago #

    Add it in manually to your Categories when Writing a Post. Then it should appear after that as a Post Category.

  3. silentmatt
    Member
    Posted 7 years ago #

    Oh, this is the problem. It already DOES appear as a Post Category. We've used it on something like 30 posts already, so it is definitely in the list.

    It is already selected as the default category under the Options\Writing tab but, when we go to write a new post, NO category is selected by default.

    Other weirdness: it appears if you save a draft, and then come back to it.. it suddenly gets the default category tag. But not if you just pull up a new post.

  4. silentmatt
    Member
    Posted 7 years ago #

    I just tested it with another one of our categories... no matter what is selected, the default won't be applied when a post is first created.

  5. MichaelH
    Member
    Posted 7 years ago #

    Oh, sorry, misunderstood. Developers thought it better to have no Category prechecked in the Write->Post screen.

    http://trac.wordpress.org/ticket/3281

  6. silentmatt
    Member
    Posted 7 years ago #

    Ohhhh.... I see.

    So, is there any workaround? ie. can I edit edit-form-advanced.php to make it checked by default again?

  7. MichaelH
    Member
    Posted 7 years ago #

    If you do that, please remember you may need to make that change in future upgrades.

    Of course, with the coming Tagging ability being added to 2.3 the code might look different...

  8. silentmatt
    Member
    Posted 7 years ago #

    hm, good point.

    thanks for the input! I definitely appreciate it.

Topic Closed

This topic has been closed to new replies.

About this Topic