WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Default Subscribe2 Page ID not updating (8 posts)

  1. kevinp93
    Member
    Posted 2 years ago #

    Hi there,

    The "Set default Subscribe2 page as ID" function doesn't seem to work on WordPress blog.

    I'm using the latest version of WordPress and the latest version of the plugin.

    When I select a page and save the settings, then press Subscribe from the widget, it transfers me to the original page.

    I have tried different browsers, and clearing the cache but that doesn't help.

    Can someone point me in the right direction please?

    Thanks.

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @kevinp93,

    You need to apply a page setting for the widget in the widget settings available on the Widget page itself, not on the main Subscribe2 Settings page.

  3. kevinp93
    Member
    Posted 2 years ago #

    Thank you. I don't understand how I missed that. To be honest I feel pretty stupid now.

    Thank you for your help.

    Btw, is there a way of customising the widget? I want to change some text (like the one in the subscribe2 textbox).

    Thank you very much.

  4. mattyrob
    Member
    Plugin Contributor

    Posted 2 years ago #

    @kevinp93,

    It's easy to miss so of the settings, there are quite a few! You can only change the text by editing the code. You need to look in classes/class-s2-frontend.php.

  5. kevinp93
    Member
    Posted 2 years ago #

    Hi there,

    Thank you. I was looking in the widget.php thinking that was the file controlling the widget. Thank you for pointing me to the right file.

    Everything works as expected.

    Thank you soo much :)

  6. Cricky
    Member
    Posted 1 year ago #

    Hi, I am having the same issue but I cannot find anywhere to change the widget settings. If I click on the widget settings it just takes me to the main widget area where you can drag it to the sidebar... what am I missing?

  7. Cricky
    Member
    Posted 1 year ago #

    Ok this is weird... I deactivated the plugin on the installed plugins page. Then I went to the Widget page and it was still there so I drug it into the sidebar and suddenly all these options showed up that weren't there before. I guess I must have done something funky when I first installed it or something... anyway problem solved I guess!

  8. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Cricky,

    I agreed, very weird. If Subscribe2 is deactivated in the Plugins page there is no way the built in plugins should be available to you on the Widgets page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic