WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Default permalinks not working (3 posts)

  1. MrJPH
    Member
    Posted 3 years ago #

    Just under a month ago, I decided to give WordPress here a try, downloaded and installed successfully, or so I thought.

    What led to my finding that perhaps my initial install was done incorrectly, was the changeover from April to May, and seeing that the Calendar and Archives widgets I had set up, when clicking in either, to pull up content from April, a '404 Page Not Found' page came up.

    I started a thread on here asking about it (and how it got marked as 'resolved', I know not... I didn't do it), and on there esmi suggested setting my permalinks back to default, to which I replied, that I had tried that, and also that the default permalinks had never worked for me from the get-go, and the only way for my posts to be published and seen, was to use any other permalink setting besides default, and then it worked, so just carried on, as I did not want the 'ugly' default permalinks anyway.

    Esmi said if the default permalinks weren't working, that there must have been something wrong with my initial install... okay, so finally this weekend, I was able to have the time to work on this, and backed-up my stuff, and then deleted, both my database created, and all files on my server, created a new database (named 'WordPress' instead of 'Journal' that it was originally), and reinstalled WP, and uploaded all WP files back up to my server.

    When I did my initial install, at the time I was thinking of having the WP portion to just be a section on my site, the Journal. So, in my used to old way of creating and setting up my websites, I created a Journal folder/directory on my server under my AnAmateurPhotographer (the name of my website) folder/directory, so that the WP generated Journal section of my website would have the path url of -

    http://www.AnAmateurPhotographer.org/Journal

    And had the above entered in as my WordPress address (URL) in my General Settings in WP. And that is also where I had all of the WP files. That was also where I thought maybe where my troubles laid in default permalinks not working.

    So, in the reinstall I did this weekend, I also concluded that I did not want to have a separate 'Journal' section that would consist of WP, but just let WP be my entire site altogether. So, installed all the WP files directly into the root directory of my site. One thing I learned this time around, that I missed with my initial install, was that the contents of the downloaded WP folder -

    If you need to upload your files to your web server, use an FTP client to upload all the contents of the wordpress directory (but not the directory itself) into the root directory of your web site.
    Well, after a long search to figure out just what the hell was meant by "not the directory itself", did I learn that WP is talking about a folder when they say 'directory'... I've just always known and called them folders, and wasn't until this weekend discovered that 'directory' is WordPressese for 'folder'.

    So, figuring that may have been where the problem was before, I correctly just uploaded the contents of the WP files into the root directory of my site. And, using the litmus of if the default permalinks work, everything this time was installed correctly and I am good to go, I left the permalink settings to default, created a post, and published, and - no dice. Trying to view the post, just opens up that if-I-see-it-one-more-time-I am-going-to-flip-out 'Index of /' screen that shows a list of all the WP files.

    What am I doing wrong?! I feel like a complete idiot that I cannot get this to work, especially when WP labels it all as a "Famous 5 minute install" ... well, yeah, I install and seem to have it all done, and done correctly, except for the fact that it's own default settings don't seem to work. If I change again the permalinks to any other setting aside from the default, posts are then viewable, which bottom line is all that matters to me, that is the point of having a website up - so one's content can be viewed! But, if it's not still going to allow things like the Calendar or Archives to function properly, as before, I would sure like to know what it is I am doing wrong, or have set up incorrectly somewhere so it actually all works!

    Right now, my site's url doesn't even load anything, even though I have in the General Settings - 'http://www.AnAmateurPhotographer.org' entered into both the 'WordPress address (URL)' and 'Site address (URL)' fields, as again, I want WP to be the generator of my whole site... and under the 'Reading' settings, have for the Front Page to display my latest posts, I get that annoying 'Index of /' page... which I am really loving that visitors to my site are seeing that as they visit my site this weekend!

    Please, what is it I am doing wrong?! Any help, suggestions, pointing me in the right direction, will be so very much appreciated and valued! And I thank you in advance for taking the time to assist me!
    JPH

  2. MrJPH
    Member
    Posted 3 years ago #

    Can images be posted in these forums? I don't see a way to do so...

    Anyway, I was thinking and was wondering if I really didn't upload the WP files to my root directory like I thought, and took a couple of screenshots of my FTP editor to show you, since it would make it easier to show you visually, than my, I am sure failing attempt, to explain it textually here...

    Here, I just created a test post, and included the screenshot images in there, asking what it is I am asking, and wondering if I may still have the WP files in the wrong location -

    http://www.anamateurphotographer.org/05/15/2011/test/

  3. MrJPH
    Member
    Posted 3 years ago #

    I think I may have discovered the problem -

    On my website's settings, I thought I had, but turned out I didn't, have 'index.php' included as an directory index along with 'index.html'.

    So, with the 'index.php' applied, I went back to my WP admin page, and gave it the default permalinks litmus test, and for the first time since I initially downloaded WP at the end of April, default permalinks worked, and not only that, but the Calendar and Archives Widgets functioned and pulled up previous month's entries. Woo-hoo! :-) [Fists and arms extended straight up in jubilation]

    Then, I went back to the custom permalinks that I want to instead use -

    /%monthnum%/%day%/%year%/%postname%/

    And then the Calendar and Archives Widgets again failed to work and instead brought up the -

    Not Found
    Apologies, but the page you requested could not be found. Perhaps searching will help.

    Argh! :-( So what is the problem now?!

    I even made the permalink so it began with the month-day-year, then postname, as WP itself says -

    Starting Permalinks with %postname% is strongly not recommended for performance reasons.

    Personally, I would just like for the permalink to just be the postname, but I am fine with having the post's date before the postname - if it works!

    So, what would be causing the Calendar and Archives to not be working now with that permalink structure, but work with the default permalinks?

    Does something need to be modified in my .htaccess file? :

    AddHandler phpini-cgi .php
    Action phpini-cgi /cgi-bin/php5-custom-ini.cgi
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

Topic Closed

This topic has been closed to new replies.

About this Topic