WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Facebook: Advanced Sharing Optimization for All Social Websites
[resolved] Default image for hompage sharing (8 posts)

  1. Fonfon
    Member
    Posted 1 year ago #

    Hi,
    The option "Default Image on Indexes" is activated and the "Default Image URL" is completed, but when I share the homepage on facebook, the picture used is the featured image of the last published post.

    Any idea about why the default image set in the options is not used instead ?

    Thanks
    Fonfon

    http://wordpress.org/extend/plugins/nextgen-facebook/

  2. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    You'll have to turn on debug mode (bottom of the NGFB settings page), and give me a URL to an example webpage.

    Thanks,

    js.

  3. Fonfon
    Member
    Posted 1 year ago #

    Hi,
    It's turned on.

    You can try it on http://www.florifere.ch (the homepage). The Default Image URL is set to : http://www.florifere.ch/images/logo_florifere.png.

    Thanks,
    Fonfon

  4. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, got it. You're right, that feature must have broke a little while back -- the image detection functions were overhauled quite a bit, and that part of the logic didn't work anymore. Download and install the DEV version at http://downloads.wordpress.org/plugin/nextgen-facebook.zip, and let me know if that fixes your problem. In fact, leave debug mode on after you install it so I can have a look at well. ;-)

    Thanks,

    js.

  5. Fonfon
    Member
    Posted 1 year ago #

    It works with the DEV version !
    I've let the debug mode activated.
    But I've found that the homepage returns the tag og:type with the value "article" instead of "website".

    Thanks,
    Fonfon

  6. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Ah - thank you for catching that. I've re-worked the og:type article/website detection code and it should work much better now. ;-)

    You'll have to download and install the DEV version again.

    Thanks,

    js.

  7. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Fonfon,

    Please let me know if everything is working correctly now. I'd like to close this issue.

    Thanks,

    js.

  8. Fonfon
    Member
    Posted 1 year ago #

    Hi,
    It works !

    Many thanks,
    Fonfon

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.