WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Defalt theme - background colour outside around page (13 posts)

  1. timo0403
    Member
    Posted 8 years ago #

    Hi

    I know there is already a post on this but I have amended the css as follows to have an orange colour however it is still appearing grey:

    /* Begin Typography & Colors */
    body {
    font-size: 62.5%; /* Resets 1em to 10px */
    font-family: 'Lucida Grande', Verdana, Arial, Sans-Serif;
    background-color: #E69821;
    color: #333;
    text-align: center;

    Blog is at http://www.voipworking4you.info/Blog

    many thanks

  2. maerk
    Member
    Posted 8 years ago #

    Check the other thread, it's been solved for you :)

  3. timo0403
    Member
    Posted 8 years ago #

    Thanks Maerk

    As posted in "CSS changes don't save" Post as I think that post is complete I have not been able to resolve problem.

    I just applied the edit you recommended and Ctrl F5 (using the colour code #E69821 instead of black but it still is grey.

    URL is voipworking4you.info .

    Now I have changed it in the style.css and in the header.php but no "happy happy joy joy"

    cheers
    Timo

  4. timo0403
    Member
    Posted 8 years ago #

    I'll close this one off and stick to the "CSS changes not updating" thread as it is not actually resolved.

    Timo

  5. ebusiness
    Member
    Posted 8 years ago #

    The proposed changes do not work as there are two stylesheets on the page.

    The embedded styles contain the css

    body { background: url("http://voipworking4you.info/Blog/wp-content/themes/default/images/kubrickbgcolor.jpg"); }
    #page { background: url("http://voipworking4you.info/Blog/wp-content/themes/default/images/kubrickbg.jpg") repeat-y top; border: none; }

    Which is preventing the suggested changes working.

  6. timo0403
    Member
    Posted 8 years ago #

    Thanks

    However now I'm really confused .... is this still in the header.php file and if so what is the solution?

    I'M not great with css obviously.

    many thanks
    Timo

  7. maerk
    Member
    Posted 8 years ago #

    The CSS you want to change is in you header.php file, yes.

    Change

    body { background: url("http://voipworking4you.info/Blog/wp-content/themes/default/images/kubrickbgcolor.jpg"); }

    to

    body { background: #exxxxx url("http://voipworking4you.info/Blog/wp-content/themes/default/images/kubrickbgcolor.jpg"); }

    Where #exxxxx is whatever colour you want to change.

    Don't worry about being new to stuff, everyone starts somewhere!

  8. moshu
    Member
    Posted 8 years ago #

    I'M not great with css obviously.

    Then you shouldn't touch the default ever... It is confusing even for seasoned CSS experts :)

  9. maerk
    Member
    Posted 8 years ago #

    Then you shouldn't touch the default ever... It is confusing even for seasoned CSS experts :)

    No it's not! ;)

  10. timo0403
    Member
    Posted 8 years ago #

    Many thanks Maerk

    If you don't fiddle you don't learn I believe and in that you make mistakes along the way :)

    Like I have.

    I have amended the code in header.php as above and still doesn't want to play the game .. it really wants to be grey. I obviously amended a couple of others that I shouldn't have ie page but it doesn't affect it at the moment either .. is there css elsewhere that is overiding it?

    Code is as follows:

    <style type="text/css" media="screen">
    /* To accomodate differing install paths of WordPress, images are referred only here,
    and not in the wp-layout.css file. If you prefer to use only CSS for colors and what
    not, then go right ahead and delete the following lines, and the image files. */

    body { background: #E69821 url("<?php bloginfo('stylesheet_directory'); ?>/images/kubrickbgcolor.jpg"); }
    <?php /* Checks to see whether it needs a sidebar or not */ if ((! $withcomments) && (! is_single())) { ?>
    #page { background: #E69821 url("<?php bloginfo('stylesheet_directory'); ?>/images/kubrickbg.jpg") repeat-y top; border: none; }
    <?php } else { // No sidebar ?>

    One really silly question .. I have tried to utilise the theme editor but it has a message at the bottom that says "If this file was writable you could edit it". Where have I missed the setting? I have beem changing code in Dreamweaver .. not that I would think this would cause a problem.

    Thanks again .. go away grey colour.

  11. timo0403
    Member
    Posted 8 years ago #

    Can anyone add anything to last post of mine.

    The page initially comes up the right colour for a brief second then the grey takes over. The code I have changed is in above post

  12. acheta
    Member
    Posted 8 years ago #

    in your header file

    delete

    body { background: #E69821 url("<?php bloginfo('stylesheet_directory'); ?>/images/kubrickbgcolor.jpg"); }

    and change

    <?php /* Checks to see whether it needs a sidebar or not */ if ((! $withcomments) && (! is_single())) { ?>
    #page { background: #E69821 url("<?php bloginfo('stylesheet_directory'); ?>/images/kubrickbg.jpg") repeat-y top; border: none; }
    <?php } else { // No sidebar ?>

    to

    <?php /* Checks to see whether it needs a sidebar or not */ if ((! $withcomments) && (! is_single())) { ?>
    #page { background: #E69821; }
    <?php } else { // No sidebar ?>

    this should work. just not sure about the php in there.

  13. timo0403
    Member
    Posted 8 years ago #

    Legendary .. thanks for the fix.

Topic Closed

This topic has been closed to new replies.

About this Topic