WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Decoder theme in IE (9 posts)

  1. northtexasboxing
    Member
    Posted 5 years ago #

    I'm using the decoder them & the header section doesn't line up right in IE but looks fine with Firefox. In IE the blue bar is split in two. There's a blue bar with the link Home on it & then below that there's a blue bar with the link Uncategorized on it. In Firefox they're both on one bluebar right next to one another & that's how I want it to look in IE also. How can I fix this issue?

  2. blackmesa
    Member
    Posted 5 years ago #

    sounds like a floating element issue, can you post the url so i can look at it with firebug?

  3. northtexasboxing
    Member
    Posted 5 years ago #

  4. blackmesa
    Member
    Posted 5 years ago #

    alright, so here's the deal.. In IE6 the a tag in the your menu is taking up 100% of it's container width because it's set to display:block; and IE6 sucks.

    Try adding this to the bottom of your style.css

    sf-menu a {
    display:inline;
    }

    If that fixes the problem in IE6 then check compliant browser to make sure it doesn't break anything. If other browsers like firefox no longer works correctly then you will need an IE conditional to load a css file for just IE6.

    Let me know either way, the problem is fixable.

  5. northtexasboxing
    Member
    Posted 5 years ago #

    That worked!! Thanks a lot you're awesome!

  6. blackmesa
    Member
    Posted 5 years ago #

    Well, not yet, there is still the issue of the active link and the rollover link not filling the menu, basically the menu just needs to be put together a little different. If your ok with what you have there then great otherwise your gonna need to mess with some values to get it right on.

    Basically when it comes down to it there are 3 solutions:

    1] make the font-size for the menu fixed and then adjust the padding, height and width for the A tags until they fit perfectly

    2] build an IE6 only css file for that menu and revert the change we just made, then the css will be a less feature rich version for IE6 but work

    3] just drop the backgrounds for the A tags and use font style changes like color: instead of the background thereby avoiding the whole affair

  7. northtexasboxing
    Member
    Posted 5 years ago #

    Thanks I noticed that & figured it out. I changed the padding from 0 to 10px & it fixed the situation.

  8. the.velcroman
    Member
    Posted 5 years ago #

    Thanks I noticed that & figured it out. I changed the padding from 0 to 10px & it fixed the situation.

    Changed what setting of the padding and in what file?

    Thanks.

  9. martyz
    Member
    Posted 4 years ago #

    I was disappointed to see no built-in IE6 support with this theme. I'm fully aware of how much IE6 sucks, but still millions of people are still forced to use it, either on government computers or just non-computer people who have no clue -- and I deal with many of them.

    The above fix didn't work for me, so for anyone that's still having trouble I put this little piece in style.css and it made the menu appear horizontally in IE6:

    .sf-menu li a {
    display:inline;
    }

Topic Closed

This topic has been closed to new replies.

About this Topic