WordPress.org

Ready to get started?Download WordPress

Forums

WP-PageNavi
[resolved] Declaration incompatability error (10 posts)

  1. flynsarmy
    Member
    Posted 11 months ago #

    After upgrading to WP3.6 I'm getting the error

    Strict standards: Declaration of PageNavi_Options_Page::validate() should be compatible with scbAdminPage::validate($new_data, $old_data) in /path/to/wp-content/plugins/wp-pagenavi/admin.php on line 156

    I would suggest renaming the validate method to scbValidate? Your method definition is different to that of the parent class. Needs to be the same.

    http://wordpress.org/plugins/wp-pagenavi/

  2. flynsarmy
    Member
    Posted 11 months ago #

    It looks like in /wp-content/plugins/wp-pagenavi/admin.php you can just change

    function validate( $options ) {

    to

    function validate( $new_data, $old_data ) {
    	$options = wp_parse_args($new_data, $old_data);
  3. Lester Chan
    Member
    Plugin Author

    Posted 11 months ago #

  4. Chuck Reynolds
    Member
    Posted 11 months ago #

    yup same issue. i'm assuming will roll out in next version?

  5. Lester Chan
    Member
    Plugin Author

    Posted 11 months ago #

    Yes it will =) I am waiting for more fixes =)

  6. Juergen Schulze
    Member
    Posted 10 months ago #

    @flynsarmy
    Thank you

  7. ianarmstrong
    Member
    Posted 6 months ago #

    Not gonna lie, four months later a sub-version update would be welcome. This is annoying to change on every single project.

  8. Lester Chan
    Member
    Plugin Author

    Posted 6 months ago #

    @ianarmstrong: done, 2.84 to fix the problem.

  9. ianarmstrong
    Member
    Posted 6 months ago #

    Awesome, thanks Lester :)

    Now to warm up InfiniteWP and update a whole whack of sites. Thanks for the rapid response :)

  10. Lester Chan
    Member
    Plugin Author

    Posted 6 months ago #

    awesome =)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.