WordPress.org

Ready to get started?Download WordPress

Forums

Simple Links
[resolved] Debug Notice Undefined variable: pluralTitle (7 posts)

  1. WebEndev
    Member
    Posted 1 year ago #

    I am getting a notice in debug:

    Notice: Undefined variable: pluralTitle in C:\xampp\htdocs\cherylshireman\wp-content\plugins\simple-links\classes\simple-links-post-type-tax.php on line 159

    Plugin working though, just an FYI.
    Thanks!

    http://wordpress.org/extend/plugins/simple-links/

  2. Mat Lipe
    Member
    Plugin Author

    Posted 1 year ago #

    Hello WebEndev,

    Which version are you using of the plugin?
    Are you using a modified version?

    I took a look at the latest version 1.6.0 and line 159 of that file only has this

    ),

    Any info will help me troubleshoot. So far we have been unable to recreate the notice.

    Cheers.

  3. WebEndev
    Member
    Posted 1 year ago #

    Hello Mat,

    It looks like $pluralTitle is actually referenced on line 158:

    'menu_name' => $pluralTitle

  4. WebEndev
    Member
    Posted 1 year ago #

    Hello Mat,

    Ahh, I think I see the problem - typo on line 137:

    $puralTitle = isset( $args['pluralTitle'])? $args['pluralTitle']: $this->plural_title($title);

    Should be $pluralTitle, not $puralTitle

  5. WebEndev
    Member
    Posted 1 year ago #

    Also, line 141 should be corrected to $pluralTitle

    'name'                       => $puralTitle,
  6. Mat Lipe
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you Very much WebEndev!!
    I have implemented your fix and acknowledged you in the method's docs.

    Version 1.6.1 should be available momentarily.

  7. WebEndev
    Member
    Posted 1 year ago #

    Looking good!

    Thanks for the very fast fix for such a small item.

    Great plugin, thanks for your work!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.