WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Debug (!)Notice harm/delay cms/blogs ? (5 posts)

  1. another-webmaster
    Member
    Posted 2 years ago #

    Once a while I activate the debug option (wp-config.php)and see notices like:
    (!)Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in \wordpress\wp-includes\functions.php on line 3587
    My question, can it harm and/or does it create delays on a site or blog?
    The scripts/plugins seem to work okay so therefore my question. Or is it "just" because of not "100%" programming and more a msg which could be ignored?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    In this case, I'd suggest that you investigate the problem - otherwise your script(s) may break in future versions of WordPress.

  3. another-webmaster
    Member
    Posted 2 years ago #

    Thank you for the fast respond Esmi.

    Sadly enough it isn't my script (I am not good enough for such lol) but one of the scripts is the "WordPress Admin Bar Improved" plugin which creates 2 msg, 1 is for style and other for script. Reported them 2 month ago but seem not yet be solved. (The plugin I personally like and as mentioned seems to work correctly from the outside).

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    In that case, all you can do is report the issue to the plugin's developer & hope that it is fixed in a future update. Right now, it's not a deal breaker but it might be worth keeping an eye on the site's behaviour/performance as you upgrade WordPress.

  5. another-webmaster
    Member
    Posted 2 years ago #

    Thank you Esmi.

Topic Closed

This topic has been closed to new replies.

About this Topic