WordPress.org

Ready to get started?Download WordPress

Forums

Deactivating and reactivating: problems?? (14 posts)

  1. cbee
    Member
    Posted 2 years ago #

    I have some undefined index errors on my site. I am wondering if I deactivate, then activate some plugins, will they still "work" like before?

    There are a couple of plugins that I am concerned will not function if I do so: custom permalinks, cforms, contact form 7, wp-dbmanager

  2. I am wondering if I deactivate, then activate some plugins, will they still "work" like before?

    That depends on what's causing the error message and what the error message is.

    If the problem is a plugin: Try deactivating all of your plugins and reactivating them one at a time. When the error message comes back, that will be the plugin that is the problem.

  3. cbee
    Member
    Posted 2 years ago #

    Hi Jan, thanks!

    So, somehow updating plugins, I got these notices:

    Notice: Undefined index: path in /dataxxxxx/htdocs/wp-content/plugins/custom-permalinks/custom-permalinks.php on line 261

    many of those front and back end.

    I tried deact. custom-perma and it didn't fix anything! Not sure what to do.

    Btw, do you know if the path above is sensitive info? I wasn't sure, but I added the x's where numbers were.

  4. If it's the plugins/custom-permalinks then try just deleting that directory and see if that resolves it. Make sure to only delete that one custom-permalinks directory and nothing else.

    If that eliminates the problem it could be a conflict with another plugin or perhaps the files became corrupted.

    See if that does it, if not you can always re-install a fresh copy of that plugin.

    http://wordpress.org/extend/plugins/custom-permalinks/

    Btw, do you know if the path above is sensitive info? I wasn't sure, but I added the x's where numbers were.

    It shouldn't matter to WordPress as long as it works for your web server (the directory path I mean). Some plugins do rely on the path when looking to write data, but if that hasn't changed then you should be fine.

  5. cbee
    Member
    Posted 2 years ago #

    Hi Jan,

    Yes, it is that plugin.

    I've had it for years and use the custom permalinks. When I deactivated, I got 404s so I'm scared to delete the directory.

    Could turning off error notices in wpconfig remove those notices?

    And with regards to the path, I meant to ask if that whole path being displayed on my home page is sensitive and hackers could use it? There were numbers where I replaced with x's in my example. Thanks for your help!

  6. cbee
    Member
    Posted 2 years ago #

    Backstory: I was updating my plugins and started a new draft at the same time, then I got a lot of error notices (undefined index)so front end full of notices and back end a few listed as well!

    Also have this weird notice:

    Constant WP_MEMORY_LIMIT already defined in /data/xx/xx/x/xx/xx/user/xxxxx/htdocs/wp-config.php on line 83

    Need help!

  7. Could turning off error notices in wpconfig remove those notices?

    If you mean WP_DEBUG, then yes that may stop those error messages from being displayed.

    http://codex.wordpress.org/Editing_wp-config.php#Debug

    If you do edit your wp-config.php file then please make a backup copy first and a precaution. I'd hate for your situation to get worse because of a typo. ;)

  8. cbee
    Member
    Posted 2 years ago #

    I will try, thanks Jan.

    With regards to displaying the full path publicly on my site..is that safe?

  9. It's safe-ish.

    I know, that's not really what you wanted to read. ;)

    It would be better if you could not display that path information on your site, but that by itself really isn't a risk.

    If you are concerned about it here, then as you've already done use XXXX to hide the specifics.

  10. cbee
    Member
    Posted 2 years ago #

    Thanks, I x-ed them here but it's full on the page. Would you happen to know anything about this notice?? Constant WP_MEMORY_LIMIT already defined in /data/xx/xx/x/xx/xx/user/xxxxx/htdocs/wp-config.php on line 83

  11. cbee
    Member
    Posted 2 years ago #

    And my story was I was updating my plugins and started a new draft at the same time, then I got a lot of error notices (undefined index)so front end full of notices and back end a few listed as well!...

    That said..is there ANY way to revert back/undo to say 10 hours ago?

    And are these notices harmless in and of themselves? I'm hoping debug false will remove.

    [ Please do not bump, it's not permitted here. ]

  12. cbee
    Member
    Posted 2 years ago #

    I'm lost. I'm in my wp-config file but there is no debug comment. I wanted to turn debug to false so my site won't show notices but it's not in my file. Any ideas??

  13. Well... try the usual troubleshooting methods, all of them and make a backup first.

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  14. jglovier
    Member
    Posted 1 year ago #

    Hi cbee,

    I just installed the Custom Permalinks plugin today too, and like you I see the PHP warnings. Technically, those are "Notices", which is not an error. I'm not sure exactly what is causing the notice (could be an array which is look for a value in a key/value pair that does not exist...), but either way the notice won't hurt anything.

    Actually, what you can do in your wp-config.php file is to set WP_DEBUG to 'false') which you should not have set to 'true' for any site in production anyway) and the notices will no longer be displayed in the admin.

    Alternatively, if you want to leave WP_DEBUG set to 'true' for a development environment, you can set WP_DEBUG_DISPLAY to 'false' in the file default-constants.php (as long as you have recently updated WP, otherwise this may still be located in wp-config.php or wp-settings.php).

    Hope that helps.

Topic Closed

This topic has been closed to new replies.

About this Topic