WordPress.org

Ready to get started?Download WordPress

Forums

Dynamic Content Gallery
DCG v4.0 testers needed! (19 posts)

  1. studiograsshopper
    Member
    Plugin Author

    Posted 1 year ago #

    I know, I know, I've been promising version 4.0 of the DCG for a long time, but one of the reasons for the delay is that I haven't received enough feedback from beta testers.

    So, want to help? If so, you can grab the development version from the Developers link above and try it out.

    It goes with saying (but I'll say it anyway) - this is a beta, so don't use it on a production site unless you're prepared to sort out any problems that may arise from using untested software.

    http://wordpress.org/extend/plugins/dynamic-content-gallery-plugin/

  2. studiograsshopper
    Member
    Plugin Author

    Posted 1 year ago #

    Just to clarify...

    ZIP file download link: DCG version 4.0 beta.

  3. Stubborn_Facts
    Member
    Posted 1 year ago #

    Hi there,
    Just wanted to let you know that I downloaded DCG 4.0 beta and implemented it on one of my test sites. Seems to be working like a charm:

    http://grassrootsne.com/testsite2/

    Really like the streamlining to the user interface; was easy to use before but even clearer now.

    An interesting note: when using DCG current version on the same site, with the plugin pulling first image on post instead of featured as you have in 4.0, there was "ERROR" in the slider for one of the posts that had a PDF document at the top of the post. Featured is definitely the way to go for a lot of reasons.

    There are quite a few plugins installed on that tester and I'll have some ongoing work I'll be doing there. So far, as I said, working wonderfully, I'll let you know as I continue to muck around if anything happens with the slider.

    Let me know if you decide to make any adjustments and I'll be happy to install any additional beta version you might release. As I say, I'll be working on some things on the tester in any case. Also, let me know if I you need any additional information or feedback.

    Thanks for providing such a clean functional plugin.

  4. studiograsshopper
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Thanks for the feedback! Great to hear that it went smoothly for you. :-)

    Thanks for the feedback on the UI, too. I probably spent more time on this than on the actual "front end" code, LOL.

    Did you do a fresh install or a "manual" upgrade? If the latter, any issues with your old DCG settings?

    The old "first image attachment" method is not intuitive and therefore can be unpredictable - hence the move to Featured Images.

    I'll be doing another code review this week, but I think I'm very close to releasing this now.

    Thanks again for the feedback - really useful.

  5. Stubborn_Facts
    Member
    Posted 1 year ago #

    Hi again,
    You're very welcome. You're work on the UI was definitely worth it.

    What great questions.

    How I installed 4.0. I hesitated over that and decided since I could have trouble with 2 instances installed (although low risk if original deactivated) and it was a beta (like Forrest Gump's box of chocolates, if you know what I mean), I thought it was probably a good idea to delete the current version and start with 4.0 fresh.

    If you do ANYTHING to it from here and want me to try another beta, I'll do it manually (assuming to deactivate current before uploading the zip) to see how things would go.

    Now, regarding the settings, now that you mention it, the ONLY thing I noticed when running through them after installing 4.0 is that the numbers in the boxes didn't the match stated defaults but they also weren't the old ones. Specifically, I know "Slide Pane Height" says Default=50, but there was "70" in the box. (I left it...looked good so...if it ain't broke...). Also, height was not the default or my previous setting, but "was in the neighborhood" , ~300.

    Not sure what any of that means, other than, maybe there is a database table left behind after uninstall? and some detection (sort of) of prior settings. Anyway, I should've remembered that when giving my "report".

    I'll be checking in on the forums with some frequency since I'm doing so much testing and I'll peek my head in here in case you've added anything else.

    Thanks again.

  6. studiograsshopper
    Member
    Plugin Author

    Posted 1 year ago #

    Hi again,

    Thanks again for your feedback.

    For info, it isn't possible to run DCG 3.3.5 and v4 beta at the same time, as they share the same file and folder names (for the most part). Therefore the only option is to manually upgrade via FTP.

    If you want to downgrade again to 3.3.5, deactivate and delete 4.0 via the Dashboard > Plugins menu. This will ensure that the database options are deleted too.

    The DCG doesn't create a database table but it does store its options in the wp_options table. When manually upgrading (ie just deleting existing v3.3.5 plugin files by FTP and uploading the new ones), the previous settings should be automatically pulled in when the DCG Settings page is visited. So, theoretically, you shouldn't have experienced the SlidePane height issue you mentioned. However, I'll double check this on my test install in case I've missed something.

    I'll definitely be doing some very minor updates (plus fix, if necessary, the issue you described) before the end of this week and I'll post back when a new beta is ready.

    Cheers!

  7. Stubborn_Facts
    Member
    Posted 1 year ago #

    Thanks for checking in again. I'm just checking in myself periodically and look forward to following the method you laid out for installation with any other beta file you'll add when you've got it ready to roll.

    I'm excited to be able to deploy the 4.0 release on one my production sites, so am more than happy to help in this small way with the beta.

  8. soreelflix
    Member
    Posted 1 year ago #

    Man Ive been waiting for a long time for this lol. Cant wait for it to be available.

  9. studiograsshopper
    Member
    Plugin Author

    Posted 1 year ago #

    @Stubborn_facts
    @soreelflix

    Have you tried the beta? Thanks.

  10. soreelflix
    Member
    Posted 1 year ago #

    I would but don't have a test site. I only have One site that is being viewed every day. So I don't want to take the risk of something going wrong.

  11. Stubborn_Facts
    Member
    Posted 1 year ago #

    @studiograsshopper
    Yes, I've definitely tried the beta...I'm the one who put it on the test site.

    And a note regarding this: I decided because the beta is so stable to put it on my live/production site. It's working like a charm there, too. Cleared up a few issues with the wrong image being pulled in from posts due to the change from using "first image" to WordPress Featured Image.

  12. studiograsshopper
    Member
    Plugin Author

    Posted 1 year ago #

    @Stubborn_Facts,

    Thanks again for the feedback.

  13. SciFighting
    Member
    Posted 1 year ago #

    Hello!

    Thank you for providing this beta. The image management is much improved and the streamlined interface is also welcome. I have only one bug to report. It's a graphical glitch in the admin console. I have a screen capture of the bug. It quickly glitches in and out of this state when moving the mouse over the buttons.

    http://www.scifighting.com/wp-content/uploads/2013/04/bug-shot.jpg

    I am noticing this bug on both Safari and Chrome (Latest versions). Otherwise the plugin seems quite stable. I went ahead and put it on my production site as it resolved an issue with "Error" being found when the featured image was changed. Thanks again!

    - Luca Rajabi
    President of SciFighting, LLC.

  14. Philip
    Member
    Posted 1 year ago #

    Would love to test it out, but maybe you can help me get the current version working on my site first. Here is the code for my theme's index file: Which part of the code do I need to replace? Thanks in advance.

    <?php get_header(); ?>
    <div id="content">
    
    	<?php if (is_paged() && get_query_var('paged') > 0) {  ?>
    		<div id="breadcrumbs">
    			<a>"><?php _e('Home','themejunkie') ?></a><?php printf( __( ' Page %s', 'theme junkie' ), $paged );  ?>
    		</div><!-- #breadcrumbs -->
    	<?php } ?>
    
        <?php if(!is_paged() && (get_option('resizable_featured_content_enable') == 'on')) { ?>
    
        <div id="featured-content">
            <div class="heading">
                <span class="heading-text"><?php _e('Featured News','themejunkie'); ?></span>
            </div> <!-- .heading -->
            <div class="featured-main">
    
    <ul>
                    <?php
                    $counter = 1;
                    query_posts( array(
                  'showposts' => 1,
                        'tag' => get_option('resizable_featured_post_tags'),
                    ) );
                    if( have_posts() ) : while( have_posts() ) : the_post();
                        ?>
                        <li class="featured-<?php echo $counter; ?>"><a>" rel="bookmark"><?php the_post_thumbnail('featured-thumb-large', array('class' => 'entry-thumb')); ?></a><span class="entry-date"><?php the_time('F j, Y'); ?> ยท <?php comments_popup_link( __( '0 Comment', 'themejunkie' ), __( '1 Comment', 'themejunkie' ), __( '% Comments', 'themejunkie' ) ); ?></span><h2 class="entry-title"><a>" rel="bookmark" title="<?php the_title(); ?>"><?php the_title(); ?></a></h2>
                        <?php $counter++; endwhile; endif; wp_reset_query(); ?>
                </ul>
            </div><!-- .featured-main -->
            <div class="clear"></div>
        </div><!-- #featued-content -->
        <?php } ?>
    
        <div class="clear"></div>
    
        <?php if(!is_paged() && (get_option('resizable_news_ticker_enable') == 'on')) { ?>
    	    <div id="news-ticker">
    	        <span><?php _e('Breaking News:','themejunkie'); ?></span>
    	        <ul class="news">
    	            <?php
    	            query_posts( array(
    	                'tag' => get_option('resizable_news_ticker_tags'),
    	                'showposts' => get_option('resizable_news_ticker_num')
    	            ));
    	            if( have_posts() ) : while( have_posts() ) : the_post();
    	                ?>
    	                <li class="news-ticker">
    	                    <a>" title="<?php printf( esc_attr__( 'Permalink to %s', 'themejunkie' ), the_title_attribute( 'echo=0' ) ); ?>" rel="bookmark"><?php the_title(); ?></a>
    
    	                <?php endwhile; endif; wp_reset_query(); ?>
    
    			<span class="headline-nav">
    				<a href="#previous"></a>
    				<a href="#next"></a>
    			</span>
    	        <div class="clear"></div>
    	    </div><!-- #news-ticker -->
        <?php } ?>
    
    	<?php if (get_option('resizable_left_sidebar_enable') == 'on') { ?>
    	    <div id="left-sidebar">
    	        <?php if ( !function_exists( 'dynamic_sidebar' ) || !dynamic_sidebar('left-sidebar') ) :?>
    	        <?php endif; ?>
    	    </div><!-- #left-sidebar -->
        <?php } ?>
    
        <div id="content-loop">
            <?php if (have_posts()) : while ( have_posts() ) : the_post() ?>
            	<?php get_template_part('includes/loop'); ?>
            <?php endwhile; wp_reset_postdata(); wp_reset_query(); ?>
            <div class="clear"></div>
            <?php if (function_exists('wp_pagenavi')) wp_pagenavi(); else { ?>
                <div class="pagination">
                    <div class="left"><?php previous_posts_link(__('Newer Entries', 'themejunkie')) ?></div>
                    <div class="right"><?php next_posts_link(__('Older Entries', 'themejunkie')) ?></div>
                    <div class="clear"></div>
                </div><!-- .pagination -->
                <?php } ?>
            <?php else : ?>
            <?php endif; ?>
        </div><!-- #content-loop -->
    
        <div class="clear"></div>
    
    </div><!-- #content -->
    
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    [Please post code or markup between backticks or use the code button. Or better still - use a pastebin. Your posted code has now been permanently damaged/corrupted by the forum's parser.]

  15. Philip
    Member
    Posted 1 year ago #

    BTW, this is a subsite of the WP multisite. Philip

  16. DanWhite84
    Member
    Posted 1 year ago #

    Works like a charm! So So SO SO SOOOO pleased with this new version. I was using the "Auto" image management setting because it was just easier for a non-programmer like me, and had some issue with updating images, loading new posts, etc. Tried out this puppy on my site and it fixed every issue and is 1000% easier to use, and with the "featured image" auto image management feature I can link it easier to my posts.

    I also agree, UI is much easier to navigate, and it seems to just be leagues beyond for someone like me. Made a great plugin even better

    Bravo, and thank you.

  17. winstonsmith84
    Member
    Posted 1 year ago #

    Hello, I just loaded the DCG 4.0 beta on my site. I removed the DCG 3.3.3 through ftp and loaded the beta as dashboard install.

    I uploaded and tested the 4.0 beta version before updating to wordpress 3.5.2; and DCG 4.0 beta worked perfectly.

    However, after updating to wordpress 3.5.2 the Dynamic Content Gallery Metabox does not retain the image url upon publishing/update the post.

    I have this same problem with DCG 3.5.2 after updating to wordpress 3.5.2.

  18. jdenhaan
    Member
    Posted 10 months ago #

    Hi!

    First of all, 4.0 is a big improvement management-wise.

    Unfortunately, there seems to be a bug where the slider refuses to pull in the right image size. It always uses the full-size image, even though thumbnails that match the slider size have clearly been generated (verified via FTP). I've tried checking and unchecking 'hard crop', but no love.

  19. jdenhaan
    Member
    Posted 10 months ago #

    I have already found the problem. It's in dcg-common-core.php in the get_featured_image function. For some reason you're referencing non-existent image size names here:

    $size = 'DCG_Main_' . $dfcg_options['gallery-width'] . 'x' . $dfcg_options['gallery-height'] . '_' . $dfcg_options['crop'];

    The result of this concatenation is an iamge size that does not exist, as the only image sizes added by DCG are DCG_Main_hc, DCG_Main_br and DCG_Thumb. I replaced the line with this and it now works:

    $size = 'DCG_Main_hc';

    Note that a similar fix is required to make thumbnails work. Replacing:

    $thumb = get_the_post_thumbnail( $id, 'DCG_Thumb_100x75_true', $args );

    with

    $thumb = get_the_post_thumbnail( $id, 'DCG_Thumb', $args );

    in dcg-gallery-core.php will fix them.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.