WordPress.org

Ready to get started?Download WordPress

Forums

Dynamic Content Gallery
[closed] DCG is not working after updating wordpress 3.5.2. (41 posts)

  1. patecj
    Member
    Posted 1 year ago #

    Today, I have updated wordpress to 3.5.2 and now Dynamic content gallery is stopped to display image for new posts now. It displays image correctly for old posts but new posts.

    I have choose full url option and giving full url in "Image URL:" of DCG metabox in post page but page is not saving url at all.

    Please solve this.

    My website where i use gallery : http://news.worldsnap.com

    http://wordpress.org/extend/plugins/dynamic-content-gallery-plugin/

  2. Nosferatuvn
    Member
    Posted 1 year ago #

    Hello,

    at first i thought it was my blame....and looking for since 2 hours for the bug...

    i have the same problem.

  3. CarolinaEpicurean
    Member
    Posted 1 year ago #

    Same problem with my site: http://carolinaepicurean.com

  4. Nosferatuvn
    Member
    Posted 1 year ago #

    When will come an update ???

  5. smkyle1
    Member
    Posted 1 year ago #

    same problem for my site: http://www.laprogressive.com

  6. df
    Member
    Posted 1 year ago #

    Same issue with our site.
    After update to WordPress 3.5.2 the contents of the 'Image URL' field in the Dynamic Content Gallery Metabox doesn't seem to save on post publish/update.
    Have tested using full and partial URLs and doesn't seem to save.

  7. zdepth
    Member
    Posted 1 year ago #

    help me! i have the same problem. I use full url method & have to insert the dcg image url for a post everytime. I can enter the url on the DCG metabox but when i press 'update' for the post, the url is not there & my dcg on the front end is black!

  8. df
    Member
    Posted 1 year ago #

    As a workaround have a look into setting up default images for posts...

    http://www.studiograsshopper.ch/dynamic-content-gallery/documentation/
    'Docs - How to name and organise your default images'

    This will at least replace the black error message you receive in the dynamic content gallery for each new post until there is a fix.

  9. Nosferatuvn
    Member
    Posted 1 year ago #

    When will come an update? I need it for my page...

  10. winstonsmith84
    Member
    Posted 1 year ago #

    Same problem. After update to WordPress 3.5.2 the contents of the 'Image URL' field in the Dynamic Content Gallery Metabox doesn't save on post publish/update. I worked around for one post by setting the relevant image as the default. However, I have no idea what to do for subsequent posts. Please advise.

  11. wadams92101
    Member
    Posted 1 year ago #

    Same here. Full image method not working. I have a multi-site and it has to pull from a subdomain so default images doesn't work from main site.

  12. flagc
    Member
    Posted 1 year ago #

    Same issue here. This has pretty much brought us to a standstill as our entire website is based on the posts that display in the slideshow. Does anyone know of a comparable slider that we can switch to? Doesn't seem like the support is too great for DCG :-(

  13. abetts
    Member
    Posted 1 year ago #

    Me too!

  14. wadams92101
    Member
    Posted 1 year ago #

    As a temporary fix, while Studiograsshopper resolves the main problem, I was able to screenshot the desired photo (not necessary if you have the image to upload), upload it, go to edit post, select featured image, and go to DCG settings>Image Management and select Auto.

  15. eamondaly
    Member
    Posted 1 year ago #

    I think the issue is in dfcg-admin-metaboxes.php: dfcg_save_metabox_data is checking the value of isset($_POST['dfcg_metabox_noncename']) instead of the nonce itself. This patch should fix it:

    --- dfcg-admin-metaboxes.php    2010-12-09 14:43:52.000000000 -0600
    +++ dfcg-admin-metaboxes.php.new        2013-06-25 21:11:07.000000000 -0500
    @@ -215,7 +215,7 @@
     function dfcg_save_metabox_data($post_id, $post) {
    
            // Check referrer is from DCG metabox
    -       if ( !wp_verify_nonce( isset($_POST['dfcg_metabox_noncename']), DFCG_FILE_HOOK )) {
    +       if ( !isset($_POST['dfcg_metabox_noncename']) || !wp_verify_nonce( $_POST['dfcg_metabox_noncename'], DFCG_FILE_HOOK )) {
            return $post->ID;
            }
  16. scaleslea
    Member
    Posted 1 year ago #

    So, how do I apply this patch?

    Doc

  17. eamondaly
    Member
    Posted 1 year ago #

    1) Go to wp-content/plugins/dynamic-content-gallery-plugin/includes
    2) Save the code above to "nonce.patch"
    3) Backup the existing file with cp dfcg-admin-metaboxes.php dfcg-admin-metaboxes.php.orig
    4) Apply the patch to dfcg-admin-metaboxes.php by typing patch < nonce.patch

    Alternately, backup dfcg-admin-metaboxes.php and edit line 218:

    if ( !wp_verify_nonce( isset($_POST['dfcg_metabox_noncename']), DFCG_FILE_HOOK )) {

    to read:

    if ( !isset($_POST['dfcg_metabox_noncename']) || !wp_verify_nonce( $_POST['dfcg_metabox_noncename'], DFCG_FILE_HOOK )) {

  18. barfux
    Member
    Posted 1 year ago #

    This works, thank you!

  19. scaleslea
    Member
    Posted 1 year ago #

    That seems to be working. Thanks for the help!

    Hopefully we see an official DFCG update soon to fix this.

    Doc

  20. abetts
    Member
    Posted 1 year ago #

    Worked here too, thanks very much indeed :)

  21. achiartistul
    Member
    Posted 1 year ago #

    I have the same problem with my website:
    http://www.farulsperantei.ro/

  22. GuruMag
    Member
    Posted 1 year ago #

    @eamondaly you deserve a medal. Thanks so much.

  23. achiartistul
    Member
    Posted 1 year ago #

    I have replaced the line 218 and it's working.
    Thanks "eamondaly"!

  24. CarolinaEpicurean
    Member
    Posted 1 year ago #

    eamondaly - Your fix worked like magic for me, too!

    Thank you so much for participating in the forums and posting information that's so valuable, yet out of reach for many of us!

    Laura
    http://carolinaepicurean.com

  25. smkyle1
    Member
    Posted 1 year ago #

    I want to use eamondaly's remedy but I don't know what the heck I'm doing and am afraid to mess with the site which is live.

    Before I try to use the solution, please tell me if it sounds like I understand the instructions. By the way, I am assuming cp means cpanel.

    1) Using Filezilla ftp I found dfcg-admin-metaboxes.php

    2) I make a copy of dfcg-admin-metaboxes.php and name it dfcg-admin-metaboxes.php.original

    3) Using Notepad, I take the code eamondaly created and save it to a file that I save as nonce.patch

    Now this is where I'm lost (could be I was lost at step 3). Where do I place the nonce.patch file. Does it go here /wp-content/plugins/dynamic-content-gallery-plugin/includes

    4) then using FTP I copy dfcg-admin-metaboxes.php to my computer

    5) using Notepad I open dfcg-admin-metaboxes.php and type patch < nonce.patch I'm guessing that I'd type that at the bottom of the page

    6) then while the file is still open and still using Notepad I look for this line

    if ( !wp_verify_nonce( isset($_POST['dfcg_metabox_noncename']), DFCG_FILE_HOOK )) {

    and change it to read

    if ( !isset($_POST['dfcg_metabox_noncename']) || !wp_verify_nonce( $_POST['dfcg_metabox_noncename'], DFCG_FILE_HOOK )) {

    7) I save dfcg-admin-metaboxes.php

    8) I upload dfcg-admin-metaboxes.php to wp-content/plugins/dynamic-content-gallery-plugin/includes

    Thanks so much for providing this support

    http://www.laprogressive.com

  26. eamondaly
    Member
    Posted 1 year ago #

    No, smkyle1: the patch option is if you have shell access to your plugins directory, and it sounds like you do not. Ignore that entirely. For your environment:

    1) Using FTP, copy dfcg-admin-metaboxes.php to your computer.

    2) Rename the file on your computer to dfcg-admin-metaboxes.php.orig. That is your backup in case something goes wrong.

    3) Using FTP, copy dfcg-admin-metaboxes.php to your computer again.

    4) Open dfcg-admin-metaboxes.php in Notepad.

    5) Change the line:

    if ( !wp_verify_nonce( isset($_POST['dfcg_metabox_noncename']), DFCG_FILE_HOOK )) {

    to read:

    if ( !isset($_POST['dfcg_metabox_noncename']) || !wp_verify_nonce( $_POST['dfcg_metabox_noncename'], DFCG_FILE_HOOK )) {

    6) Save the file and close Notepad.

    7) Upload the modified dfcg-admin-metaboxes.php back to your website using FTP.

  27. Tomahoochi
    Member
    Posted 1 year ago #

    Thanks a ton eamondaly!

  28. CarolinaEpicurean
    Member
    Posted 1 year ago #

    Kudos, eamondaly! I was hesitant to try to help Tomahoochi, because I'm not an experienced coder and didn't want to confuse things.

    I've been in Tomahoochi's place, not understanding instructions.

    So I wanted to thank you for taking the time to break it down to an easy-to-follow walk-through.

  29. smkyle1
    Member
    Posted 1 year ago #

    eamondaly -- it worked like a charm!!

    Thank you for being so generous with your time.

    http://www.laprogressive.com

  30. Nosferatuvn
    Member
    Posted 1 year ago #

    THANK YOU!!! It works now!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.