WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [DB view] no management (7 posts)

  1. Mark Orie
    Member
    Posted 2 years ago #

    John,

    Been busy offline last week, so no replies in the other discussion yet. Sorry. Now there seems to be a slight problem which prevents me from testing and responding.

    I upgraded DB view to 0.4.2, but have now lost management rights, even though I am an Admin on the site. Didn't see that one comming. The "Management" link in the plugins listing tells me I do not have appropriate rights, and the menu item is gone.

    Worse: the page on which the database is viewed displays an error, stating the view is not public.

    I will try to revert to the previous version for now.

  2. Mark Orie
    Member
    Posted 2 years ago #

    I suspect "Public flag added to each view."in the changelog has something to do with this. I upgraded from 0.3.2.

    Can I set this flag in the database manually? Or is there more to it?

  3. john ackers
    Member
    Posted 2 years ago #

    Crikey, really sorry, didn't see that coming either. I have upgraded 2 sites without problem.

    On activation 'manage DB views', as per description on first page, is granted to the administrator role. Suggest first deactivating and reactivating (because I am suspicious that the plugin doesn't always get activated during an automatic install), then checking that you have the capability 'manage DB views'. There are various plugins for doing this.

    If all else fails, rip out lines 552 to 558 of DBView.class.php which test the public flag and the 'capability' of the user. I will try to provide a better explanation later. Again sorry.

    It's slightly tricky setting the public flag manually because the (db)view is a php serialized object.

  4. Mark Orie
    Member
    Posted 2 years ago #

    You were right: I checked for activation but did not de- and reactivate before. It seems to have solved all problems at once.

    The update also solved the problem with the link in the other thread

    Sorry to have caused this small scare. Great!

  5. john ackers
    Member
    Posted 2 years ago #

    Mark,
    Don't want to alarm you but all 4 dbviews on your site say 'not public'. You will need to logout to see this problem as administrators (granted with relevant capability) see everything.

    Whatever the outcome, perhaps none public views should not be displayed to administrators on public facing pages? Or at least administrators should get a warning?

  6. Mark Orie
    Member
    Posted 2 years ago #

    John,

    You did a poor job at not alarming me, and I thank you for it :-) Setting the public checkbox solved it. I did indeed see everything because of my administrator status. A warning might be in order.

    My first instinct would be to set the default for "Public" to checked. In my case, I generate a view because I want to show something, and I only put it on a page once it does show what I like. I do not know whether there would be a way to call a view which has not been officially published (i.e. put on a post/page with a shortcode), that would change things

  7. john ackers
    Member
    Posted 2 years ago #

    I think that an ajax call call from a browser could be easily modified to request different view, it doesn't really matter if it's in a page or not - so there is a big security consideration. So i don't think the default setting could not be public. I have just committed a change to add a warning message to administrators if view not public.

Topic Closed

This topic has been closed to new replies.

About this Topic