WordPress.org

Ready to get started?Download WordPress

Forums

DB Error (11 posts)

  1. rapha
    Member
    Posted 10 years ago #

    DB Error

  2. rapha
    Member
    Posted 10 years ago #

    Hi All,
    trying to install WordPress here (following the 5-minute-recipe), I'm afraid I've not come nearly as far as the other newbies :-). The error message it gives me upon calling wp-install.php is:
    DB Error, could not list tables MySQL Error: Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)
    That's probably due to my lacking knowledge in MySQL administration, but searching the MySQL docs just gave me a headache. It at least does have a root password set (`mysql -uroot -pmypassword' on the console works, and that's also the data I used for b2config.php).
    The system I'm trying this on is OpenBSD 3.4, MySQL 3.23.57 and PHP 4.3.3.
    I'd be grateful for any hints that you might have!
    Cheers, Raphael

  3. Alex King
    Member
    Posted 10 years ago #

    Have you entered that data into your settings file (this is explained in the instructions)?

  4. rapha
    Member
    Posted 10 years ago #

    > It at least does have a root password set (`mysql -uroot -pmypassword'
    > on the console works, and that's also the data I used for b2config.php).
    So the answer is yes, I have.

  5. Mike Little
    Member
    Posted 10 years ago #

    Hi Rapha,
    Which version are you using? The ucrrent version doesn't use b2config.php (other than once during an upgrade process.) Toy may want to try with the most recent version 0.72 which is still in beta but quite stable.
    Mike

  6. rapha
    Member
    Posted 10 years ago #

    Well, the file I downloaded was `wordpress-071-gold.tar.gz'. But I'll try 0.72 if you say that'll work.
    - R.

  7. rapha
    Member
    Posted 10 years ago #

    Hi again,
    I'm trying it with 0.72 now, but still the same problem -- it's not able to connect to the mySQL database. And yes, the database name in wp-config.php _is_ set correctly, as are username, password and hostname. Using `mysql -u <username> -p' is working just fine, too.
    What could this be related to?
    Best, Raphael

  8. otaku42
    Member
    Posted 10 years ago #

    Does a "ls -al /var/run/mysql/mysql.sock" show something? Are you sure that the socket is there? The other option (besides using sockets) could be to use TCP for communication. If your system has been configured like this, you had to adjust something in WordPress to reflect these settings, I guess.
    Bye, Mike

  9. rapha
    Member
    Posted 10 years ago #

    # ls -l /var/run/mysql/mysql.sock
    srwxrwxrwx 1 _mysql _mysql 0 Oct 10 00:52 /var/run/mysql/mysql.sock
    So yes, it's there. I tried using my server's IP instead of "localhost", but it doesn't look like it could be fooled that easily. So how do you get WordPress to connect to mySQL by means of TCP?

  10. Alex King
    Member
    Posted 10 years ago #

    Maybe you should create a little test file and make sure you can connect to the database?

  11. Anonymous
    Unregistered
    Posted 10 years ago #

    /var/www is chrooted....... its not possible to see beyond.....
    try ln -s /var/run/mysql/mysql.sock /var/www/var/run/mysql/mysql.sock
    it results

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.