WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Dates in Snippets / Removing / Published Time / Modified Time (4 posts)

  1. Chris
    Member
    Posted 9 months ago #

    Hello,

    Can someone confirm this setting is working on the latest version of WordPress SEO: 1.4.19

    I'm trying to disable the date showing up in Google. There is a setting in WordPress SEO > Titles & Meta > Post types > Pages > Date in Snippet Preview: (Unticked)

    I only want the pages to be disabled with the date. However ticking this box on or off has no effect on these fields:

    <meta property="article:published_time" content="2013-11-12T19:57:40+00:00" />
    <meta property="article:modified_time" content="2013-11-14T08:23:03+00:00" />

    can someone please confirm if this is working on their install?
    Or is this tick box supposed to do something else?

    Thanks

    http://wordpress.org/plugins/wordpress-seo/

  2. Page404
    Member
    Posted 9 months ago #

    Uncheck if u don't want the date showing up in search engines. However, if this box was checked before publishing your post, the date is going to show up in google.
    if it's now unchecked, then the post needs to be recrawled and indexed before changes can be made. You may use 'fetch as google' tool from WMT to fetch it

  3. Chris
    Member
    Posted 9 months ago #

    Hi Thanks for your help. We found more information that everyone might be interested.

    In fact this menu option:
    WordPress SEO > Titles & Meta > Post types > Pages > Date in Snippet Preview: (Unticked)

    Has nothing to do with Google. All this field does is show the snippet date in the editor of the wordpress admin. When you create a new post, WordPress SEO shows a snippet preview in wordpress admin. This removes the date / adds the date to the preview.

    The ONLY way to remove the date from Pages and Post is to edit your template from your theme. single-post, single-page . PHP files. Just remove the dates even if you use display:none in CSS to hide it, I would suggest removing the php code that generates it completely.

    Then go into Google webmaster and fetch or resubmit your sitemap.

    Sorry this had nothing to do with the Yoast Plugin after all. Got confused with the terminology in the menu options.

  4. Capt_E
    Member
    Posted 9 months ago #

    I was also confused by this. I am using twenty thirteen theme and in the post and page php files, there doesn't seem to be any code generating the google search date snippet. Any ideas how else to remove it?

Reply

You must log in to post.

About this Plugin

About this Topic