WordPress.org

Ready to get started?Download WordPress

Forums

Participants Database
dates don't get saved (14 posts)

  1. knireis
    Member
    Posted 1 year ago #

    I start a new topic, checkbox issue is solved but I still have a problem with the dates when entering them as '20 January 2012'. After pushing 'apply' dates still show. But after a refresh or submit the dates are gone. I enter them in the same format as in the basic wp settings and have the Strict Date Format option checked.
    When i change the wp basic setting to 20/01/2012 all works ok.

    Anything to do with the localizing issue?

    http://wordpress.org/extend/plugins/participants-database/

  2. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    What is your general date setting when you are experiencing the problem?

  3. knireis
    Member
    Posted 1 year ago #

    20 januari 2012 (in Dutch)

  4. knireis
    Member
    Posted 1 year ago #

    I think we're getting close to the problem.

    The general setting is as above. When i enter the date in Dutch it does not stick after submit.
    When i enter it in English (20 January 2012) it sticks but it is displayed in Dutch (20 januari 2012), but submitting it again (with the date displayed in Dutch) makes the date disappear again, probably because it is in Dutch.

    It does not matter if the strict date format option is set or not.

  5. knireis
    Member
    Posted 1 year ago #

    latest version shows this behavior as well

  6. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    knireis,

    Yes, this hasn't been fixed yet.

  7. knireis
    Member
    Posted 1 year ago #

    Dates are now saved in correct language but there is a new issue. Everytime I select apply the date is decreased by 1 day.
    For example i enter 2 juni 1964, hit apply and the record shows 1 juni 1964, hit apply again and it shows 31 mei 1964.

  8. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, I'm sorry I have not found a working solution for saving localized dates yet.

  9. knireis
    Member
    Posted 1 year ago #

    I would like to get going with the plugin. Is there a possibility to workaround the issue of the date decreasing with 1 day everytime i save the record?
    Maybe just leave it in English for now and when later on the issue is solved, be able to translate to Dutch?

  10. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    knireis,

    I think you'll need to do it in English or use numeric dates. I still haven't figured out how to make it work in another language.

  11. knireis
    Member
    Posted 1 year ago #

    Hi, I tried several possibilities but none work, only thing that probably works is to change my wordpress install to english, but then all dates on the site are displayed in english.......
    Just hope you'll find a solution. Thanks for helping me sofar.

  12. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    Did you try numeric dates? That should work.

  13. knireis
    Member
    Posted 1 year ago #

    Sorry, i can't get that to work either.
    In the general settings I have: d-m-Y, entering a date like 02-06-1964 is being saved as 01-01-1970. I have strict setting on or off does not matter.

  14. knireis
    Member
    Posted 1 year ago #

    I just noticed that when i select the standard setting 02/06/1964 in the general settings it works ok.
    Now i have to hope that the dates i use in the calendar and on other places on the website stay in the desired '01 May 1965'format.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.