WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7 Datepicker
Date picker / calendar showing below footer!? (13 posts)

  1. Mark Smallman
    Member
    Posted 1 year ago #

    On every page I have used the Date-picker it is showing the calendar below the footer. It's not there when a date is selected in the inquiry form.
    See http://www.scotiaheritage.co.uk/contact-us/
    How can I remove it from below the footer... it should not be there in the first place!?

    http://wordpress.org/extend/plugins/contact-form-7-datepicker/

  2. ratputin
    Member
    Posted 1 year ago #

    I was experiencing the same issue. I deactivated/activated it and it seemed to sort itself out.

  3. jzahlaway
    Member
    Posted 1 year ago #

    Having the same problem, and the solution offered above (deactivate/reactivate plugin) does not resolve issue. Please advise. Thanks.

  4. Mark Smallman
    Member
    Posted 1 year ago #

    De-activate & re-activate didn't work for me either.
    Nor did removing the plugin and re-installing.

    So obviously I am not the only one to find this issue.

  5. matthewclagg
    Member
    Posted 1 year ago #

    I am experiencing the same issue at http://www.matthewclagg.com/consuelodavis. The datepicker shows up below the footer until it is activated in the contact form. It appears that it is not being hidden upon page load, then moves when activated in the form.

  6. bronzina
    Member
    Posted 1 year ago #

    I've just updated to 2.3.1 and now work correctly.

  7. spcaer
    Member
    Posted 11 months ago #

    Go to your settings page for the form you're having problems with. In the 'Datepicker Theme' Meta Box make sure you select a 'Theme' from the drop menu and select 'Save'.

  8. iconoclastix
    Member
    Posted 10 months ago #

    Hi, I'm having the same problem with the datepicker on my contactform7 form as well.

    I've tried deactivating/reactivating it, but it doesn't work.

    I've also selected a theme from the form settings page (Redmond) and have saved it, but it still doesn't work - even though I've selected a theme and saved it, the datepicker appears to not be saving my changes (it still looks like the "Base" theme). Not sure if there's a save issue that's causing the datepicker to appear below the footer.

    I'm using the latest versions of WordPress, ContactForm7 and ContactForm7 Datepicker plugins.

    Any help?

  9. iconoclastix
    Member
    Posted 10 months ago #

    ^^ Also, this seems to only be happening in Firefox...it appears to work fine in Chrome as well as IE (even though IE is doing some really weird things to my layout, but at least the datepicker isn't displaying below the footer).

    Has anyone been successful in finding a fix for this?

  10. spcaer
    Member
    Posted 10 months ago #

    Please post a link so I can see the page causing problems. Also, have you tried disabling all other plugins to see if the issue is resolved?

  11. iconoclastix
    Member
    Posted 10 months ago #

    Here's the page: http://experience.nipissingu.ca/home/

    I haven't tried disabling the other plugins, however, ContactForm7 & CF7 Datepicker were the first two plugins I activated on the site and this was the first page I created, and this problem has been happening ever since.

    Like I said it only appears to be happening in Firefox, but I would obviously hope that it would work properly in all browsers...

    Thanks for any help!

  12. iconoclastix
    Member
    Posted 10 months ago #

    On the form you'll see that once you click inside the "Tour Date" field (which is the datepicker field) it moves to the correct location...but when the page loads in Firefox, you should see the datepicker already activated, below the footer. Not sure why this is happening!

  13. spcaer
    Member
    Posted 10 months ago #

    I just tested the page in Firefox 18.0.1 & 21.0 on Mac and 21.0 on PC and the calendar doesn't show in the footer on page load. Perhaps you have a browser extension enabled that's causing you problems. If you can rule out browser extensions, I'd recommend switching your theme to Twenty Twelve to see if the issue still exists for you. If so, then there is some sort of conflict in your theme.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic