WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Date in google description SERPs causing poor ranking (5 posts)

  1. lesb55
    Member
    Posted 1 year ago #

    Despite using this plugin with carefully crafted meta titles no wider than 469 pixels (yes its pixels now - NOT 70 characters), and carefully written meta descriptions; Google-bots aggressive use of dates has resulted in our home page being displayed with the 'first published date' showing at the start of or homepage meta description.

    Does this affect your rankings?

    YOU BET IT DOES!
    Like: dropped from #7 on the first page of Google search results, to #25 (3rd page of search results).
    This is an ecommerce site and the first published date IS NOT RELEVANT to the content on this page.

    Followed the advice on this site: http://www.webmasterworld.com/google/3843934.htm

    After 1 month of trying everything else (with virtually zero sales),
    this is the ONLY way we were finally successful in stopping Google from showing that ancient 'first published' date at the beginning of our homepage description:
    Added last_modified meta date to the header.php (as the first meta tag):
    <meta http-equiv="last-modified" content="YYYY-MM-DD@hh:mm:ss TMZ" />

    Added last modified date to the homepage.php file:
    Updated: <?php the_modified_time('F jS, Y'); ?>

    Changed the published time on the actual page (wp-admin) to todays date, and re-published the page.

    Resubmitted the xml page sitemap in webmaster tools, did a 'Fetch as Google' in webmaster tools, then submitted URL for re-indexing.

    Within 10 minutes our website was back on the first page of Google search results - WITHOUT A DATE BEING SHOWN!

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. lesb55
    Member
    Posted 1 year ago #

    One more thing I forgot:

    WordPress SEO> General Settings:

    Add noodp meta robots tag sitewide: checked
    Add noydir meta robots tag sitewide: checked

    This is to stop the intellectually-challenged googlebot from using the oldest possible date it can find; cached in either the DMOZ or Yahoo directories.

  3. Mark_Nexus
    Member
    Posted 11 months ago #

    Fantastic advice. Just registered here to say thanks. My snippet was showing an old review date and slipped 5 places on the 1st SERPS page overnight. Followed this post and site is back to #4, in 10 minutes like you said. Thanks!

  4. mani4astro
    Member
    Posted 11 months ago #

    Hei can i use this line of code on my wordpress site ? If yes , please let me know , where do i have to add the code ,

    in functions.php file ? or soemwhere ?

    I also have doubt that,

    if my post published on August 15th, 2013 , it is ranking for a keyword, and if i update the post on august 22, 2013 ,

    if a user search the keyword , and will the date on the serp will show August 22, or August 15th ??

    Please do reply ..

  5. lesb55
    Member
    Posted 11 months ago #

    @ mani4astro

    Forget about adding the meta date to your header.php.
    I have since found out that Google bots pay almost no attention to meta date tags (these days).

    The other advice still holds.
    You really do need to be using Yoast's WordPress SEO plugin, then turn off caching in both the DMOZ or Yahoo directories.

    What code you would need to add, to which theme templates, will depend on your theme.
    Better for me to direct you to a post by John Lamansky, who explains this better than I can:

    remove post dates

    And this one:
    remove date from search results

    Finally;
    Updating a post will not stop google from using the 'first published' date.
    If all else fails; you can change that troublesome 'first published' date (to something more recent), on the actual post page in WP admin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags