WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Date format for calendar link not working (2 posts)

  1. wp-tam
    Member
    Posted 1 year ago #

    When I click the widget calendar link to December 7, 2012, the link that is generated is:
    http://www.revenuegrowthclub.com/members/2012/12/07/

    Instead of going to that url, it gets automatically redirected to the home page:
    http://www.revenuegrowthclub.com/members/

    The url that does work to show the posts for that day is:
    http://www.revenuegrowthclub.com/members/2012/12/7/

    So the date has changed from "07" to "7" without the zero. However, the calendar will not link to that url, and it's a different format from all the other calendar days.

    All the other date links from the calendar that I have tried work, including other single-digit days.

    A little background: I have been attempting to get password protection on the blog posts so it will be a membership site. I have tried three member access/privacy plugins, to no avail. Finally, none of the posts would come up under any circumstances. This problem persisted even after all the member access/privacy plugins were disabled. Resetting permalinks solved the problem *except* for this one calendar link.

    Any suggestions for making the posts come up at http://www.revenuegrowthclub.com/members/2012/12/07/ ?

  2. wp-tam
    Member
    Posted 1 year ago #

    Never mind, I worked around the problem by changing all the posts that had been published on December 7th to December 6th. Now it all appears as it should.

Topic Closed

This topic has been closed to new replies.

About this Topic