WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form DB
Date format display doubled up (3 posts)

  1. pjamedia
    Member
    Posted 1 year ago #

    When I use the [cfdb-datatable] shortcode, the first column displays the 'Submit Date'. The data is displaying digits doubled up, for example, where I would expect a date (in UK format dd/mm/yy) such as 16/02/13, it is displaying 1616/0202/1313.

    Also is there any way to control the order that columns appear in the [cfdb-datatable] output? I have 4 file upload fields in my CF7 form, and in my [cfdb-datatable] output the first upload field is displaying as one of the latter columns by itself in the display, isolated from the remaining 3 upload fields which appear together in the centre of the column ordering, leftwards by several columns from that first one.

    Any ideas?

    Thanks, Paul

    http://wordpress.org/extend/plugins/contact-form-7-to-database-extension/

  2. Michael Simpson
    Member
    Plugin Author

    Posted 1 year ago #

    Order of columns: use the "show" option on the short code to list the columns in the order you wish to see them.

    Date format: I don't know why it is double up but try this:
    - go to WP admin page -> Contact Form DB -> Options
    - "Use Custom Date-Time Display Format" = true
    - "Date-Time Display Format" = d/m/Y
    - Save changes

  3. pjamedia
    Member
    Posted 1 year ago #

    I changed to the Custom date format, exactly as you suggested, but the date format in the returned [cfdb-datatable] for 'Submit date' is still the same. I do have other dates which are manually entered into the form in CF7, and these are displayed correctly. Its just the submit date which is incorrectly displayed.

    Cheers, Paul

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic