WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
[resolved] Date field now essentially required (8 posts)

  1. jrwmacdonald2
    Member
    Posted 10 months ago #

    When including a date field users can no longer choose not to fill it out. They get the error: "Please select a valid date in this format: mm/dd/yyyy"

    I believe this started happening with the last update.

    http://wordpress.org/plugins/si-contact-form/

  2. Mike Challis
    Member
    Plugin Author

    Posted 10 months ago #

    Please post a URL to your form.

  3. Mike Challis
    Member
    Plugin Author

    Posted 10 months ago #

    If it is not required you can leave the field as is: mm/dd/yyyy and submit the form.
    If you delete the mm/dd/yyyy, and submit, it will show that error. But maybe if it is not required, and it is blank, it should ignore that. is that the problem?

    Mike

  4. jrwmacdonald2
    Member
    Posted 10 months ago #

    That is how we used to use it - we'd just leave the field with the default mm/dd/yyyy and hit submit - no error. But It no longer allows that (the field is set to not required).

  5. Mike Challis
    Member
    Plugin Author

    Posted 10 months ago #

    A URL to your for would be helpful to me to verify problems.

    I am re-coding so if not required, it can be blank, and it can be default mm/dd/yyyy and hit submit - no error.

    This will be fixed in Beta 4 tonight, not sure if any more 3.xx versions will be released.

  6. jrwmacdonald2
    Member
    Posted 10 months ago #

    I'd love to give you the URL - unfortunately its not available outside our network. (We use the form to capture reference question statistics at an academic library - it is a fabulous plugin by the way).

    I'm not sure when I'll be able to move to version 4. Any idea when the problem crept in - perhaps i can roll back to an earlier version until I can move to 4?

    Thanks for your super fast response to this.

  7. Mike Challis
    Member
    Plugin Author

    Posted 10 months ago #

    I patched it into the 3.xx version but did not change the version, so this is how to get the new code:
    http://www.fastsecurecontactform.com/update-to-the-latest

  8. jrwmacdonald2
    Member
    Posted 10 months ago #

    Wow thanks for the quick response - works! Thanks Again!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.